PDA

View Full Version : procmail Enforcing stricter permissions...



junga
02-07-2004, 07:26 PM
I am getting this message in maillog on every email to any email box [username].


Feb 7 14:38:07 junga.com procmail[1672]: Enforcing stricter permissions on "/var/spool/mail/[username]"

I set the permision on all my email boxes to -rw-------, and I can send a test message without getting the message. But then after a short while I check and the something has changed the permissions back to -rw-rw---- and I am getting the above message in the log again.

Any ideas? All mailbox files are owned by my domain account and are in group vuser.

--BobG

FZ
02-07-2004, 08:35 PM
This isn't specific to your account; I get the same thing. Since it just seems to be a warning and not a fatal error, I think it is safe to ignore it. Come to think of it, I think I noticed that the default -rw------- is changed to -rw-rw---- when you access the mailbox in question directly, e.g. through pine. I could be wrong though...

junga
02-07-2004, 08:46 PM
Its just annoying that the log gets clogged up with them. I am thinking about writing a little program to analyze maillog and that would easily ignore them. I am totally getting obsessed with unix and sendmail admin now:)

I don't pine, but now I notice that after I coolect mail with a pop client the permissions are back to -rw-rw----. Maybe with the VDS, the mail client needs to access the mail file as the group vuser?

BlueSphere
02-16-2004, 03:42 PM
junga,

I think that if the mailbox permission is too loose, then procmail will try to fix it. You can stop procmail from doing this by setting the mailbox u+x bit. I'm not sure if this is the best thing to do, but I think it will do the magic.

What I think is happening is that the pop daemon doesn’t change back the permission from 660 to 600 if there is any mail left in the mailbox. However, it does everything correctly if you empty your mailbox.

Hope this helps.

-Boris