View Full Version : Building Emacs -- help!

02-06-2004, 10:43 PM

I've tried building every version of emacs I can get from GNU under the VDS and they all core dump. No idea why.

Anybody had any success with any versions? I can't abide vi and pico.


02-07-2004, 03:23 AM
Take a look at matts site, he seems to have got it working:


04-10-2004, 12:16 PM
I tried following the recommendations for installing emacs, including removing the -g flag from gcc, but still got the segmentation fault. Given that a lot of folks who like emacs, me (a clueless newbie to westhost) asks: What would be involved in getting the powers that be to make emacs an installable package, just like the Gnu compiler tools? This would certainly simplify its installation for those that want it.


04-10-2004, 02:50 PM
I don't know if this is the problem, but I tried installing an earlier version (20.7, vs 21.3), and got the same problem. Reading the etc/PROBLEMS file, I found this:

* On Linux-based GNU systems using libc versions 5.4.19 through
5.4.22, Emacs crashes at startup with a segmentation fault.

This problem happens if libc defines the symbol __malloc_initialized.
One known solution is to upgrade to a newer libc version. 5.4.33 is
known to work.

Does anyone know what version of libc we have? Looking in /usr/lib, I found
/usr/lib/libc-2.2.5.so, but the version number seems so old it is likely not the right thing.


04-14-2004, 12:26 PM
[1] Westhost is using glibc2, version 2.2.5. The latest is 2.3.1. So the problem in etc/PROBLEMS didn't apply, but the glibc version WAS part of the problem.

[2] By jove, I think I've got it!

After suspecting the problem was in the malloc, and the call to malloc, and that configure was quite likely giving the wrong answer, I tried something... and it worked!

To get emacs 21.3 to run on westhost, you need to do the following:

(1) After unpacking the emacs .tar.gz, edit "configure", and change the line

(2) Next, do what Matt suggests at domsch.com:
./configure --prefix=/usr/local --with-x=no \
--without-toolkit-scroll-bars --without-xim

(3) Next, do a make and a make install. It appears you don't have to worry about the -g.

I now appear to have emacs running. So far, no problems.



04-14-2004, 02:08 PM
That's great to hear! I had not gotten back to you via email on my attempt to compile on my test account but it was a failure... mainly because I have that account limited to 150mb and I think I ran out of space... not to mention the other problems you where haveing. It does seem that this is a pretty big package and might take up alot of room.

The one thing that I was not sure of being a newbie to all this was the line you repeated from Matts suggestion

./configure --prefix=/usr/local --with-x=no \
--without-toolkit-scroll-bars --without-xim

Is that supposed to be typed on one line before you hit the return when you are in SSH? That is what I did not knowing for sure.

Is emacs simply used in an SSh session or is it usable via a browser. I am still not sure what it is used for but all this has sure got my curiosity up! I really did try to sort it out by reading the info on it on different sites like Red Hat and others but it just didn't seem to sink in.

I am glad to hear you got it up and running.

04-14-2004, 02:32 PM
The "\" was a line continuation.

As for what emacs it: it is a multi-window completely extensible text editor. At work, I both read mail and read news in it. It also has a directory editing modes (which makes life a lot easier in getting everything setup).