PDA

View Full Version : MojoMail scripts are no longer working...



maida
12-22-2003, 02:32 PM
My MojoMail scripts are no longer working...

http://www.true-believers.com/cgi-bin/mojo/mojo.cgi

It was working last week, and now it isn't...weird. I haven't touched this site in over a month, so I don't know why it would just quit working.

Any help would be greatly appreciated.

Thanks!

Maida

Here is an example of the errors.

Software error:
Can't locate Net/DNS/RR/SIG.pm in @INC (@INC contains: ./ ../ ../../ ../../../ ./../../MOJO ../../perllib ../../MOJO ../perllib ../MOJO perllib ./MOJO ./MOJO/perllib /usr/local/perl/lib/5.6.0/i686-linux /usr/local/perl/lib/5.6.0 /usr/local/perl/lib/site_perl/5.6.0/i686-linux /usr/local/perl/lib/site_perl/5.6.0 /usr/local/perl/lib/site_perl .) at MOJO/perllib/Net/DNS/RR.pm line 81.
For help, please send mail to the webmaster (Postmaster@true-believers.com), giving this error message and the time and date of the error. Content-type: text/html

Software error:
Can't locate Win32/Registry.pm in @INC (@INC contains: ./ ../ ../../ ../../../ ./../../MOJO ../../perllib ../../MOJO ../perllib ../MOJO perllib ./MOJO ./MOJO/perllib /usr/local/perl/lib/5.6.0/i686-linux /usr/local/perl/lib/5.6.0 /usr/local/perl/lib/site_perl/5.6.0/i686-linux /usr/local/perl/lib/site_perl/5.6.0 /usr/local/perl/lib/site_perl .) at (eval 20) line 2.
For help, please send mail to the webmaster (Postmaster@true-believers.com), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Mon Dec 22 14:20:48 2003] mojo.cgi: Can't locate Win32/Registry.pm in @INC (@INC contains: ./ ../ ../../ ../../../ ./../../MOJO ../../perllib ../../MOJO ../perllib ../MOJO perllib ./MOJO ./MOJO/perllib /usr/local/perl/lib/5.6.0/i686-linux /usr/local/perl/lib/5.6.0 /usr/local/perl/lib/site_perl/5.6.0/i686-linux /usr/local/perl/lib/site_perl/5.6.0 /usr/local/perl/lib/site_perl .) at (eval 20) line 2. BEGIN failed--compilation aborted at (eval 20) line 2.
For help, please send mail to the webmaster (Postmaster@true-believers.com), giving this error message and the time and date of the error. Content-type: text/html

Software error:
Can't locate Net/DNS/RR/SIG.pm in @INC (@INC contains: ./ ../ ../../ ../../../ ./../../MOJO ../../perllib ../../MOJO ../perllib ../MOJO perllib ./MOJO ./MOJO/perllib /usr/local/perl/lib/5.6.0/i686-linux /usr/local/perl/lib/5.6.0 /usr/local/perl/lib/site_perl/5.6.0/i686-linux /usr/local/perl/lib/site_perl/5.6.0 /usr/local/perl/lib/site_perl .) at MOJO/perllib/Net/DNS.pm line 31.
For help, please send mail to the webmaster (Postmaster@true-believers.com), giving this error message and the time and date of the error. Content-Type: text/html; iso-8859-1; charset=ISO-8859-1

maida
12-30-2003, 11:18 PM
Argh...I just checked on my ticket #205550 and it was marked as RESOLVED even though I still have the problem :x

I read through the error messages more closely and it seems that the program is looking for 2 files:

Net/DNS/RR/SIG.pm
Win32/Registry.pm

From my research, these files should both be part of the standard Perl library...any chance that WestHost modified/updated/moved the Perl library on this server?

Anyone know where the Perl library sits so I can check it?

Maida

blakekr
01-12-2004, 04:06 PM
I just got this error with my mojo script -- I'm not *writing* mojo scripts, I'm just using the auto-generated HTML template. Error log shows this problem:

[Mon Jan 12 16:01:22 2004] [error] [client 24.48.66.103] malformed header from script. Bad header=/dead.letter... Saved message : /var/www/cgi-bin/mojo/mojo.cgi
didn't close pipe to '|/usr/sbin/sendmail -t' - at /MOJO/Mail/Send.pm line 676.
[Mon Jan 12 16:02:02 2004] [error] [client 24.48.66.103] malformed header from script. Bad header=/dead.letter... Saved message : /var/www/cgi-bin/mojo/mojo.cgi
didn't close pipe to '|/usr/sbin/sendmail -t' - at /MOJO/Mail/Send.pm line 676.
[Mon Jan 12 16:02:15 2004] [error] [client 24.48.66.103] malformed header from script. Bad header=/dead.letter... Saved message : /var/www/cgi-bin/mojo/mojo.cgi
didn't close pipe to '|/usr/sbin/sendmail -t' - at /MOJO/Mail/Send.pm line 676.

I didn't see this before ... any ideas? Anyone else having problems?

blakekr
01-12-2004, 04:12 PM
Well, this is odd -- can't be SURE, but it seems like I only get an error when I input an email address that matches the account's main domain.

maida
01-12-2004, 10:55 PM
Well, I ended up upgrading to Dada mail and everything seems to be working fine now.

I don't know why it just crapped out for no reason after a couple of months of working fine -- it's not like I changed anything.

Gotta love technology. :wink:

Maida

blakekr
01-13-2004, 01:24 PM
I take it Dada mail is something you installed through SSH?

Mojo mail isn't working at ALL -- throws errors when people try to subscribe and sends me notification of new subs -- so I just came back here to look for suggested alternatives.

maida
01-13-2004, 02:11 PM
Dada mail is actually the new and improved Mojo mail...they had to change the name due to copyright infringement or something.

Anyway, I just installed it along with my old Mojo mail and was able to use the existing archive and member lists, which was a big plus. You can download it here:

http://mojo.skazat.com/

Here's a direct link to the upgrade FAQ:

http://mojo.skazat.com/support/documentation/UPGRADE_README.pod.html

I installed it using FTP, not SSH...so it was pretty straightforward. You only have to edit the Config.pm file using the same variables as the Config.pm file in your current mojo installation.

I just upgraded 3 of my clients to Dada from Mojo, and things seem to be working fine for all of them.

I'm watching the topic so I can check back here to see if you try this and if I can help you in any way.

Good luck!

Maida

blakekr
01-13-2004, 07:01 PM
Maida, THANKS! I think I'll download this and try it ASAP. Much appreciated, especially you having gone to the trouble to post links.

maida
01-13-2004, 11:40 PM
You're welcome. I have gotten a lot of help from people in this forum, and I'm glad to have the opportunity to pass on some of my experiences.

Let me know how it goes... If you run into any problems, I can do my best, but I can't promise I can fix anything. ;)

Good luck!

Maida

wildjokerdesign
01-14-2004, 08:24 AM
Hi maida,

Hope you do not mind but I added your comments about Dada Mail to my board. I did give you credit for the infromation. :)

maida
01-14-2004, 08:52 AM
Of course I don't mind...although it's actually more of an upgrade than an alternative.

WestHost says they will upgrade to DadaMail at some point...if their users keep having problems with it, they will have to do it sooner than later, so hopefully it will be sooner :)

Maida

BTW, I like the new look of your site...it's changed since I was last there.

wildjokerdesign
01-14-2004, 09:03 AM
Thank you for the site compliment. I well change ther alternative to Upgrade and I think I well add your comment about WestHost thinking of upgradeing if they continue to have problems.

blakekr
01-20-2004, 03:26 PM
Okay, here's the deal. I uploaded and installed Dada, and got the same exact errors as before. The error ONLY occurs when I have someone confirm their subscription, and they hit the confirm link. They get an ugly Error 500, and the error log says:

Tue Jan 20 13:24:04 2004] [error] [client 67.23.231.99] malformed header from script. Bad header=/dead.letter... Saved message : /var/www/cgi-bin/dada/mail.cgi
didn't close pipe to '|/bin/sendmail -t' - at /home/[blahblah]/dada/DADA/Mail/Send.pm line 696.

I took this to the Mojo/Dada support forums and was told that this is a continuing problem at Westhost because the control panel has screwed up sendmail, or something like that.

So my question is, has *anyone* gotten Mojo/Dada to work correctly when the subscriber confirms their opt-in? (Have you tested this on your own site?) If so, how did you do it?

maida
01-20-2004, 03:48 PM
Bad header=/dead.letter... Saved message : /var/www/cgi-bin/dada/mail.cgi
didn't close pipe to '|/bin/sendmail -t' - at /home/[blahblah]/dada/DADA/Mail/Send.pm line 696.


The path to sendmail is


/usr/sbin/sendmail

Your error message says
/bin/sendmail

Could that be it?

Maida

blakekr
01-20-2004, 08:49 PM
Well, heck, let's find out.

I did not configure mojo mail and I got this same error.

I *did* configure Dadamail and I got this error ... if you do "which sendmail" from the shell, it says sendmail should be /bin/sendmail.

I'm gonna change it and let you know if it worked. In any case, you're my hero for suggesting stuff, LOL.

wildjokerdesign
01-20-2004, 09:13 PM
I don't know if this has anything to do with this but. Some folks where having problems with scripts that sent out mail because it was sent as Root. If then they got a mail sent back the got permission errors on it because Root was not a user. The fix was this supplied by Chris Simiskey:


To resolve returned mail to root problem
1. In /etc/aliases add the following line:

root:username

where username is the name of the user you want to send root messages to

2. From SSH, run the following command:
sendmail -bi

Doing the above edits the aliases, and then tells sendmail to rebuild that alias database.

I would say that even if it is not the problem it would be a good thing to do if you are sending out confirm e-mails. I have a couple scripts that do it and did the fix so I would no get the error.

blakekr
01-25-2004, 09:15 PM
Thanks so much for the suggestion. Unfortunately I still get the "didn't close pipe" error when the script tries to send out email. Wish I could figure this out; maybe I ought to look for an offsite newsletter handler.

maida
01-26-2004, 09:32 AM
Sorry to hear of the problems you are having. That is just so strange...don't you just love technology?

I did get an email today that a new version of DadaMail has been released today DadaMail 2.8.12

Sorry I can't be of more help. :(

I suppose you have already tried a totally new clean install just for kicks. :?

Maida

blakekr
01-26-2004, 01:24 PM
I think I'll give it a few more tries, just because it would be really nice for my little businesses to have a working newsletter. :)

Hey, if anyone besides Maida, WildJokerDesign and I are reading these posts, are *you* getting mojo/dada mail to work and send out emails correctly?

If others are having success I'll feel more encouraged, LOL.

jalal
01-26-2004, 01:51 PM
Hi Blakekr

In short, yes, mojo is working for my clients.

But I don't have an insight into what your problem is (in fact I've lost track of what the problem is, this thread seems to have wandered a bit).

But, the bit about "didn't close pipe" reminds me of problems with formmail, discussed on another thread somewhere here, and the problem was that if formmail was set up with a recipient address on the local domain AND that address existed BUT the /ftp/usr/somename directory didn't exist (which is the home directory for 'somename' as referred to in /etc/passwd) THEN there was an error in trying to deliver the mail.
So, whatever email you are using on the server, make sure that it exists and has a home directory.

Sorry if that sounds a little confused but its not easy to explain, there is another thread somewhere here with a few more details.

HTH

blakekr
01-26-2004, 03:20 PM
I have a very strong feeling you're onto the source of the problem. So you can't use aliases then, I guess, as newsletter 'owners.'

Thank you so much, you can bet I'll be looking into it.

maida
01-26-2004, 03:36 PM
Oh wow. I can't believe I didn't think of that...I was trying to use an alias as a list owner a while back, and I had trouble with MojoMail/DadaMail, but it wasn't the same error you were getting. I hope that this is the answer you have been looking for! :)

Maida

blakekr
01-26-2004, 09:54 PM
Well, here are the results.

Dada simply won't work as long as the list owner is an address on our server (e.g., our domain is routesix, so no routesix address will work as list owner -- even if it is a full, legitimate email address -- nor will any of the various aliases).

However, dada works perfectly as long as I make the listowner address belong to a domain that has nothing to do with the server.

Aggravating as heck and yet very gratifying to have a temporary solution at least. Thank you so much for pointing the way!

jalal
01-27-2004, 07:59 AM
Are you sure that the routesix address has a home directory???

By this I mean that if you have dingbat@routesix.net there must be a directory /ftp/pub/dingbat.
(this directory is defined in /etc/passwd)

This is something that is coded into sendmail and cannot be changed, it checks for that directory before accepting an email.

blakekr
01-27-2004, 11:06 AM
Oh, okay I see (after a night's sleep).

Yes, the dingbat@routesix.com addresses most definitely have home directories, but not an ftp account. So I guess that's what is tripping things up; no ftp account.

Not in a million years would I have figured out that was the problem.

jalal
01-27-2004, 11:12 AM
No, they don't need an ftp account... its just that when you create an email address in Site Manager, the only way to get a home directory created is to create the email addy with FTP enabled. You can then disable FTP, thats no problem. (yes, its a bug in Site Manager).

The key is, that whatever directory is listed in /etc/passwd for that user has to exist. Whether or not SIte Manager creates it or you create it by hand doesn't matter.

blakekr
01-27-2004, 11:17 AM
Well shoot, I hope someone else finds this thread because I think it will be of use to several people as they mess about with mojo and dada mail. :)

Thanks, Jalal!

scubajoe
01-10-2005, 01:55 PM
Well, I just found this thread! Bingo! This issue has been bugging me for months, although my lists were working fine. I just could not get my "listmanager" address to work. It is the only address without FTP. All of my bounces were going to my "root" account "admin". So, it looks like I should be able to fix this problem, but there still remains the issue of the list owner being at AOL, and not getting list admin e-mails (I get all of those at my "admin" account as well). I think that might be related to e-mail authentication - too lazy to look up the 3-letter neumonic for what I am thinking of (SDF?).

-Joe

wildjokerdesign
01-10-2005, 03:21 PM
Do you mean SPF? Sender Policy Framework (http://spf.pobox.com/)

scubajoe
01-10-2005, 03:43 PM
Yeah, that's it! I've been reading up on it a bit. I am assuming that is why e-mail from Mojo for that list owner at AOL ends up at my admin account. I did test out the other suggestion about creating the home directory, and it did not appear to make a difference. Oddly, if I set the list owner to joe@scubajoe.net (at my domain), then I get the list e-mails, and subscription notices. This is with the admin set to listmanager@scubajoe.net.
I take that back. I just looked again. Mojo is running slow like molasses. I am getting mails now that were sent HOURS ago! I don't understand why it does this, but wonder if doing the upgrade to Dada will be better. I need to back up my data first, which is the only reason I haven't tried the upgrade yet.

-Joe

maida
01-10-2005, 07:34 PM
I had a really tough time upgrading from Mojo to Dada with the data. I had to go in and rebuild all the archives by hand.

This was because the original files I had in my archives were not in plain text, the db file was encrypted.

Something you might need to watch out for, I'm not sure.

Also, I'm not sure what version you are currently running, but here's a link to help with the upgrade:

Upgrading to Dada Mail from Mojo Mail 2.8.9 and Below
http://mojo.skazat.com/support/documentation/mojo_to_dada.pod.html

Good luck! It's a pain, but has been totally worth it.

Maida

scubajoe
01-10-2005, 08:02 PM
I'm hoping westhost has that figured out since the install for Dada can now be done through the site manager, but I intend to back it all up, just in case. At least I'll have the data, should I need to rebuild it all by hand.

Thanks for the link. I'll check it out.

maida
01-10-2005, 08:35 PM
When I did my upgrade, I was able to run mojomail and dadamail at the same time on the same server. Since the file names/directories are all different, there was no chance of overwriting the old stuff.

Hope that helps!

Maida 8)

scubajoe
01-11-2005, 08:49 AM
It did look like that was the case, but the backup will make sure it doesn't mess it all up. I guess then I just need to go into site manager and change the command line argument to point to dada instead of Mojo. That sounds pretty easy.

From others it sounds like I'd be better off going and installing Ilohamail or something, but I just don't feel like getting into that right now. I'm just figuring out all of the quirks with Mojo!

The only thing that is not working now with my lists is that bounces are going to "root". What I have is the owner of the list as "joe@scubajoe.net", and the list admin as "listmanager@scubajoe.net". List messages (for the first time ever) and subscribe and unsubscribe notices, now get to "joe@scubajoe.net", but the bounces are still going to "root@scubajoe.net" which end up at "admin@scubajoe.net". Not a major problem, but I have a few lists set up for others, and I'd prefer the bounces to go to them, not to me.

-Joe

maida
01-11-2005, 10:53 AM
I believe this is related to another issue since the 2.0 upgrade with root@domainname.com being the only address to receive bouncebacks. I tried to do a search on the forum for posts related to that issue, but got no good results.

I would post that as a separate, specific thread in the email forum to see if you can catch the attention of a WestHost tech. Something like "mojomail bouncebacks go to root instead of list admin"

I'd love to get that resolved myself. Right now, I forward the bouncebacks to the list owners.

Maida

wildjokerdesign
01-11-2005, 10:55 AM
I think the fact that the bounces go to "root" has to do with how sendmail runs. I think there is a way around by running sendmail as a daemon but since I am not familiar enough with sendmail I have never tried to make any adjustments.

scubajoe
01-11-2005, 07:09 PM
I figured it out. OK, thruthfully I was poking around the sparse Dada mail forums, and found the solution.
Under "Sending Options", "Advanced", there is a box to add a "-f username@domain.com" option to sendmail to force it to send your admin e-mail address as the bounce address. I tested it, and changed all of my lists. Everything is working perfectly now.
It took over a year, but I've finally got all of the bugs out (I hope)! Of course, now I am going to back up my data, and install Dada, and get that set up. Hopefully some of the other quircky behavior, like Mojo just stopping, or taking several hours to forward mail, will go away.

-joe

maida
01-11-2005, 08:24 PM
Thank you for that. In dadamail, the setting is in the same place and the checkbox reads:


[b]Add the Sendmail '-f' flag when sending messages, using /usr/sbin/sendmail [/b]
Sometimes the Return-Path header, useful when dealing with bounced emails, will not get set correctly. To fix this, messages will be sent with the '-f' flag and the admin email:

|/usr/sbin/sendmail -t -f comics@bargaincomics.com


Seems to be working just fine. I tested it by sending an invitation to a known working address and a known nonworking one.

Thanks again!

scubajoe
01-11-2005, 08:28 PM
Yep, that's the same checkbox as in Mojo! Glad we were all able to figure this out. That stupid little box was hidden. Luckily they pointed straight to it in the Dada forums.

Off to back up Mojo and install Dada.

-Joe

scubajoe
01-14-2005, 09:22 PM
BTW, the install of Dada from the site manager has an option to "upgrade" which I figured meant that it would point to my existing data. Well, it copied everything to a new location and deleted the original installation of Mojo. I was able to just copy it back to get my lists back up and running until I had a chance to test out Dada completely, but I just switched all of my lists over to Dada and everything appears to be running well.

One thing I can't find any information on is the difference between 2.8.14 (onthe site manager) and 2.8.15 (the latest version). No release notes for it on the website for Dada.

-joe

maida
01-15-2005, 11:55 AM
I hope you reported this issue to tech support. They need to put a note on the site manager and let people know that the original install will be deleted.

I'm glad it all worked out.

Maida