View Full Version : Imagemagick (again)...

12-09-2003, 07:11 PM
I was just wondering if anyone has got Imagemagick working 100% or not. I've been trying to get it working for the past two days. Using http://www.photopost.com/magicknoroot-php.html as a guideline, I can get it installed into /usr/local/ImageMagick with no problems, and it works for the most part, except for when I need to perform font/text related things, such as -draw 'text 10,10 "Testing"'. I have tried absolutely everything:

1. FreeType2 is apparently already installed, but ImageMagick ./configure says that the library is incomplete, so it refuses to use it. I did another (complete) installation (separate directory) of FreeType2 and specified the path with ./configure but it still refused (guess it was still picking up the original and not the new one).

2. I've installed GhostScript and its associated fonts. This helped a bit in that the "sh: gs command not found" disappeared, but now I get:

FreeType library is not available ...

which is silly because I specified it should use a Postscript font (since TTF fonts will only work if Freetype is available). I've tried configuring GhostScript with the ttf option as well, but that did not help. My paths are also correct: ImageMagick picks up the correct file in /usr/local/share/ghostscript/fonts but it just refuses to use it because of FreeType! :evil:

Also, if anyone from WestHost is reading this: please add ImageMagick to Site Applications!

Thanks in advance...

01-15-2004, 07:16 PM
WestHost has responded about ImageMagick in this post http://forums.westhost.com/phpBB2/viewtopic.php?p=8694#8694 that is a link to my last post in the area. If you scroll up you well see what WestHost had to say.