View Full Version : Updating DNS entries.

11-13-2003, 04:17 PM
If I transfer an existing domain from outside of Westhost to my reseller account, surely all I need to do is create the account. Right?

But how do the DNS entries (within Westhost) get updated?
I've created an account, but the ns?.west-datacenter.net name servers haven't got an entry in them. Is there another step???


11-13-2003, 08:52 PM
I got this in my New account e-mail.

Domain Name Servers (DNS)
If your client's domain names are not pointed to our name servers, you can access the account by going to http://your-domain.com.yourtempsite.com/ (replace "yourdomain.com" with your domain name).

To point your client's domain names to our name server, you will need to contact the Registrar for each of their registered domain names and have the name server settings (DNS) changed to the following:

Primary Name Server

Secondary Name Server

Does that answer your question? I am not sure about the
http://your-domain.com.yourtempsite.com/ (replace "yourdomain.com" with your domain name). That is just a bit confusing to me.

11-13-2003, 11:47 PM
yes all u've got to do is add the domain into your acount & change the dns server name in the domain registrar to as stated in the names above respectively.
the registrar will take 24 hrs to update your change .
if u change now tomorrow 1200hrs +8GMT will be up already

11-14-2003, 12:39 AM
Hmmm, didn't work for me.

Shawn, they are talking about modifying the registrars DNS to use Westhosts name servers. But if there is no entry in Westhost's NS for the domain then it doesn't work.

Justus, so it seems it should happen automatically and hasn't. Time to open up a support ticket. Thanks guys.

11-14-2003, 01:05 AM
yes i had the same problem you've mentioned, just remembered.

someone told me ait be due to the cache in your isp that wasnt the problem when i checked.
so i guess it was the host dns problem, bcoz i previousl had 1 domain pointed to the hosting's dns & then 2 days later it was still no connection.

then i changed it to westhost dns & hosted it there it showed up.

btw netsol registrar is rather slow to update - that was the problem i had with netsol only while the other registrars was no problem.

11-14-2003, 03:04 AM
But surely when I query Westhost's servers like so:
$ dig @ns2.west-datacenter.net mydomain.com

then they should have a record pointing to Westhost?

The registrar will not update their records until Westhost recognizes the domain as being local ("Not Authorative...") to Westhost.

11-20-2003, 06:51 PM
I'm also having the same problem here, so how did you solve it Jalal?
Submit a ticket ?

11-21-2003, 09:26 AM
I submitted a ticket... which, after a flurry of emails finally seems to have been resolved.
The nameserver records should have been created by the account manager but they weren't. Even though I told Westhost that the records hadn't been created, it wasn't until the third email (and three days) and I sent them a printout of a query on their own nameservers that they admitted that there had been a techinical error. So, do a 'dig @ns1.west-datacenter.net yourdomain.com' for each of the nameservers, save the output in a file and send it on with the ticket.

The second thing was that I was trying to transfer a German '.de' domain and the German registry insists that the primary and secondary nameservers be on separate subnets and ns1 and ns2 are on the same subnet, so I had to get Westhost to setup ns4 (which is on a different subnet) for me. Its been 8 days now and I hope that the issue is resolved. I've just put in a request for the transfer to happen again.

11-21-2003, 05:20 PM
But surely when I query Westhost's servers like so:
$ dig @ns2.west-datacenter.net mydomain.com

Just to make sure I understand this comment. You where in a SSH session at the domain you where trying to get going?

You know me still learning. :)

11-21-2003, 09:26 PM
Ok I got my answer form above. One of my accounts went down and when I checked in my resellsers manager it was there but when I accessed its site manager to check the DNS settings they where all blank. I tried to put them back in and got errors of all kinds.

So I decided to try the dig thing. Went in to my main account via SSH and did a dig in the account that was down I used all the new ones and old ones for DNS. This is it what it gave me on all

(1 server found)
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 6
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; downeddomain.com, type = A, class = IN

;; Total query time: 0 msec
;; FROM: mymaindomain.com to SERVER: ns.westserver.net
;; WHEN: Fri Nov 21 21:15:51 2003
;; MSG SIZE sent: 37 rcvd: 37
If I do a dig on one of my accounts that are still up I get good info no SERVFAIL and if finds 3 servers. The new DNS seemed to give me a

; Bad server: ns1.west_datacenter.net -- using default server and timer opts
But still found the info for the account that is still up.

Well I am mainly leaveing this as a trial in case it will be helpfull to others or if I get an answer on what happens and give the fix.

If WestHost looks in on this post it is ticket#158258 where I detail the problem. I did take jalal's advice and add the dig info to the ticket.

Need to go check if I got an answer from it been in exploretory mode for a bit. :)

11-21-2003, 10:12 PM
Recieved a response from WestHost and the techs are looking at it. I will let all know what the outcome is. Hmm not a bad response time.

11-21-2003, 10:14 PM
My problem was probally a case of my ISP cache and a little panic :)
Will keep this thread in mind :)

11-24-2003, 09:13 PM
If you all run into a problem where you do a dig or host (on Linux) or nslookup using our nameservers (both ns.westhost.net and ns1.west-datacenter.net) and you get NOTHING, please shoot us a ticket and let us know. Due to a DNS problem, a few sites seemed to 'disappear' from the nameservers, but we're working on getting all the DNS entries all straightened out and get the programmers to fix whatever caused that for good. It all seems localized to one specfic group of accounts, but we need to know if anyone else runs into another account where the same thing happened.

11-24-2003, 09:28 PM
At the moment 3 of my sites seem to fluctuate can see can't see, after changing to westhost dns the last 3 days.

I'll shoot them a ticket as mentioned.