View Full Version : FTP Folder Error - Permissions Denied

10-08-2003, 02:55 PM
I have been working on getting my counters back up and running after changing host. I have the counters working but need to update the counters for each page to match the numbers from before moving the site. I tried goinging into the stat.dat file to edit the file. When I tried to ftp the file, I got the following error below even after checking to make sure permissions were set correctly.

Permissions for the whcounter folder in the cgi-bin is already set at 755. After that, the files within that folder do not allow me to change permissions or upload new dat. I can change permissions in the guestbook folder but not whcounter folder. What can I do to update pages with actual counts instead of starting the counter over?

FTP Folder Error
An error occurred copying a file to the FTP Server. Make sure you have permission to put files on the server.

200 Type set to I.

200 PORT command successful.

553 stat.dat: Permission denied.

10-08-2003, 04:18 PM
I just tried it out, and it worked for me out-of-the-box: I did not have to change any of the default permissions, etc. (I installed the counter for the first time). Uploading an updated stats.dat via FTP worked and did not product that error message. You might want to re-check your permissions:

-rw-rw-rw- 1 root root 2476 Sep 6 08:39 config.txt
-rw-rw-rw- 1 root root 22 Oct 9 00:10 stats.dat
-rwxr-xr-x 1 root root 11844 Sep 6 08:39 whcounter.cgi

If that still does not help, try using Pico via SSH to edit stats.dat (I tried that before using the FTP method and it worked).

10-08-2003, 06:48 PM
I have checked and rechecked several times the chmode settings and they are set the same as you listed and these were actually the settings already set when I clicked to have the counter set up today with the manager for setting up the counter under Tools. Right from the start it set itself up in the cgi-bin folder. The cgi-bin folder is set to 777 and the whcounter folder is set to 755. Even if I try to change the whcounter chmode, it won't allow any changes and resets itself as well as the files within the folder and sends up the FTP Error message. I even tried to delete the folder and try to set it up from scratch and it will not even allow me to delete the folder. Says access is denied. I can ftp the stat.dat to the cgi-bin but not to the whcounter file. :(

10-08-2003, 08:26 PM
Try using the File Manager supplied with the Site Manager to edit the stats.dat As a rule I do not encourage use of the supplied File Manager but thought I would see if it was possible to edit the file with it on my account and it worked. Like Fayez I am able to use FTP to upload the file without getting any errors and my permissions are set the same. What FTP program are you using to upload with?

10-09-2003, 12:28 PM
I figured it out... :lol:
The old host had the folder name in front of the file which I had to delete and also used a "," before the actual count and Westhost uses an "=" sign. I was able to make the chages after comparing and then it did allow me to upload the new stat file with the corrections. So that was the problem and not the Permission settings.

Thanks you to those that offered suggestions!