View Full Version : root@domainname.com ????

10-07-2003, 06:58 AM
Ticket #114440 williamtucci.com

I keep getting messages that I don't have permission for root@williamtucci.com for
bounceback messages.

Not sure why or how this account is being used instead of the default account.

Any ideas?



10-07-2003, 08:55 AM
Do you have any scripts that mail to you? I have one that I wrote that does an automactic mail to me whenever someone adds to a certian page. On the old system it always sent to an alias I had set up but now it sends it to me from root@mydomain.com . I need to give the script a look and see what I have set wrong but have not worried about it since I am still getting the notifications.

10-07-2003, 11:34 PM
Here is the message I get:
The original message was received at Mon, 6 Oct 2003 22:13:35 -0600
from localhost
with id h974DYK29293

----- The following addresses had permanent fatal errors -----
(reason: permission denied)

----- Transcript of session follows -----
procmail: Insufficient privileges
550 5.0.0 root... Insufficient permission

So, where is root being set as the default? Can I change this somewhere? I am using Mojomail and YaBB Forum, both of which send automatic messages to members (topic replies, subscription notices, etc). These bounceback messages are being sent to root for some reason.

Any ideas?


10-08-2003, 11:10 AM
Well for me it was becuase I forgot to set the from variable in my script so I guess the the system defaulted. I was playing with Mojomail one day and got the same erro but since I do not use it I just kinda forgot about it. Some of the other forum users have more knowledge of procmail so hopefully they will chime in but I will continue to look and see if I can figure anything out.


10-10-2003, 04:00 PM
Well, I looked and in YaBB, there is a setting for the admin which has been, and still is pointing to a valid email address.

I played around with Mojo as well and could not find anywhere to set a default mailing address, except for each individual list, which are set to a valid email address.

So, this must be something built in somehow.

Still no reply from WestHost support.

3 open tickets...

10-10-2003, 04:34 PM
So I gave in and finally called tech support.

30 minute hold time.

Anyway, it seems that you cannot accept bounceback emails at an aliased address, only to an actual user account.

So the solution that was given to me was to change the admin address to a user account instead of the email alias I was using.

I'll let you know if it works.


10-10-2003, 05:11 PM
Cool glad to hear you got an answer. I kept looking but could not figure it out so was laying low hoping someone else would chime in. It kind of makes sense. Let us know.


10-10-2003, 05:19 PM
Actually that did not work.

After 30 minutes on initial hold and then an hour on the phone for various tickets...

Turns out that, prior to 2.0 email bouncebacks automatically went to domainname@domainname.com (default email account).

With the 2.0 "upgrade" the SMTP sends using root, and bouncebacks automatically comes back through root, which does not exist.

So, this is a "feature" of 2.0 and apparently they haven't figured out a work around yet.

Some might find this trivial, but I am list administrator to a number of good-sized mailing lists. And, with every mailing comes a good number of bouncebacks.

Well, since root is not valid, it gets forwarded to postmaster and now the bounced back email address is buried inside an attachment email.

Which doesn't sound bad until you think about having to open an attachment on each and every one just to get to an email address which I used to be able to grab straight out of the email.

Which on a bad day could be 100 emails.

Just another annoyance of 2.0. And something I can't believe that they can't fix.


10-11-2003, 12:04 PM
Madia and WesHost,

Here is a link to a thread that I belive is related

Hopefully if one is answered the other user will not be left out in the dark if they watch the other thread.

12-10-2003, 02:59 PM
I am also getting the root@ permission denied errors.

I tried setting up an alias of root to be delivered to my main account, no that failed as it says root is reserved by the system admin.

Okay the problem I thought was procmail, but its not that. As you stated messages are being sent root@domainname.com

Tracking this further its sendmail!

Okay as support seem 'unable' to fix this, I will have a go at editing sendmail and see if i can force it to send using another 'valid' address

I also have large list and these root bouncebacks are getting out of hand.

WestHost - CSimiskey
12-12-2003, 11:12 AM
To resolve this problem (and I am responding to your ticket as well Aus-City) do the following:

1. In /etc/aliases add the following line:
root:username where username is the name of the user you want to send root messages to

2. From SSH, run the following command:
sendmail -bi

Doing the above edits the aliases, and then tells sendmail to rebuild that alias database. I am doing the above to your account, but the above should be good for anyone in the future wanting to take care of these.

12-14-2003, 06:40 PM
I'll give it a try, but it will be a few weeks before I send out another mailing to test it out.


Thanks! I hope it works!