View Full Version : Unable to send email in NeoMail

09-23-2003, 10:51 AM
I Installed NeoMail app and everything is working fine except for one small glitch. I can send and receive email to and from any address other than those at the same domain.

In example, say my email address is emailaddress1@mydomain.com. I am unable to send email to emailaddress2@mydomain.com, emailaddress3@mydomain.com, etc.

Thanks for taking the time to read this post. Any help would be appreciated.

09-23-2003, 06:16 PM
What type of an error does it give you if any? This is a new one I have not heard of yet.

09-23-2003, 09:45 PM
When I hit send it does go to an error screen.

Error message:

Sorry, there was a problem sending your message. Please click your browser's Back button, check your message, and try again.

Also, when I go to my inbox after getting the error there is a returned mail message from the mail server.

Mail server message:

This is a MIME-encapsulated message

Reporting-MTA: dns; mydomain.com
Arrival-Date: Tue, 23 Sep 2003 21:39:13 -0600

Final-Recipient: RFC822; emailaddress2@mydomain.com
Action: failed
Status: 5.0.0
Last-Attempt-Date: Tue, 23 Sep 2003 21:39:13 -0600

09-24-2003, 08:14 AM
I tested my Neomail and it sends e-mails to other mail accounts on my domain with no problems. Did you install Neomail pre-2.0? Perhaps you should try re-installing it.

09-24-2003, 08:21 AM
Sorry some more questions for you. Are the other addresses set up as users or just aliases? I tried to recreate the error through one of my accounts and was not able to.

The one thing that comes to mind is to make sure that if the email addresses are set up as users that they have e-mail privildges.


09-24-2003, 11:17 AM
I set up my hosting with WestHost after y'all moved to 2.0. I tried reinstalling NeoMail though, still getting the same errors. Possibly this is a problem with how the users accounts are set up...

09-24-2003, 11:22 AM
Checked the user settings and they are set up under the email/ftp management as users with email enabled not as aliases. I tried setting up an aliase to catch a users email and send it to their box, just for fun, that did not work either.

Thanks for taking the time to test this on your accounts. So far no luck... :roll:

09-24-2003, 11:31 AM
The test accounts I sent it to are normal E-mail/FTP account users set up with the Site Manager, each having 10MB quotas and FTP access disabled (of course that should not make any difference). Maybe you should check your mail log (/var/log/maillog) to see if it can give you any helpful hints as to what the problem is.

09-24-2003, 02:30 PM
Fixed! :D

Not sure why, but it appears the users had to be set up initially with ftp access enabled. I edited each of the users adding ftp access and can now send emails locally on the domain. I disabled ftp access again on each of the user accounts and emailing is still a go.

I dont get it, but it worked.

09-24-2003, 02:48 PM
Glad to hear it!

11-04-2003, 09:07 PM
ceward, I had the same problem. I was pulling my hair out until I stublmed across your post. I also setup my emails without FTP access. I now went and added FTP, did a test email and it worked. Removed FTP access and it still worked.

There must be a bug in the app or something is needed in Neomail that requires the ftp directory created when you setup the FTP for each client.

But anyways, I got my accounts fixed.

11-05-2003, 06:11 AM
I think it ties in with the "forward: no home" error. In other words, the bug that requires all local mail addresses/accounts to have a home directory. Setting an account up with FTP access (via the Site Manager) is the only way to give an account this capability easily. Like you said, you can then remove it if you don't want FTP access. Doing this (assigning home directories) also solved a problem with (other) scripts that tried to deliver e-mail to local mailboxes.

11-06-2003, 02:20 PM
Thank god someone else has seen this, it was not looking pretty to debug. I was experiencing both of these issues, and the magic solution seems to have worked for me as well. Now I can move on to saving some other part of the world ;-)....