View Full Version : Can I retrieve missing email?

09-19-2003, 07:59 PM
I'm sorry to say this but I have been spending the evening looking at alternatives to westhost.

Today broke the camel's back so to speak. I think I am going to bail on Monday with 5 sites.

Today was a day where all of our emails seemed to get lost. Or we would get one out of two. Same thing with sending - many would disappear or every other one would go thru. All of this includes mailing to and from non-westhost accounts. As I am typing this message some emails from 8 hours ago are showing up. But we know others are missing.

We haven't been able to reliably email between our 5 sites now for three weeks.

Which brings me to my question - is there a directory I could look in to see if any emails are queued up?


09-19-2003, 08:04 PM
try /var/spool/mail
There is also a /var/spool/mqueue


09-19-2003, 08:31 PM

There were about 60 files in mqueue. It appears to be 30 header types and 30 corresponding body types or 30 messages in total.

It is like decoding a puzzle but at least we know who some of the people were that tried to contact us.

Thanks for yoor help.


09-20-2003, 05:06 AM
I think this is related to some kind of very serious configuration problem I ran into a week ago. Charlie: Do you have SpamAssassin installed? If so, remove/uninstall it. Then try sending/receiving your e-mails again. It won't immediately solve the problem, but e-mails you send/receive after you have done this should come through immediately. To confirm this is the same SA bug I found, at the SSH command prompt type:


If you see a lot of "sendmail" entries then yes, it is the same bug I came across. If not, then it isn't. Besides checking the mail queue, you can take a look at /var/log/maillog which is the log file for incoming and outgoing e-mails.

09-20-2003, 06:20 AM

I do have spamassassin installed. In my case, it is now 7am here, the 30 emails that were stuck last night, showed up. Whether there are more lingering or not I do not know because I have not tried what you said.

We are leaving for two days - I will try what you said upon our return.

In the meantime, what did you do about the bug in spamassassin?


09-20-2003, 08:56 AM

I forgot to mention that in my case the problem only seemed to occur if I used a custom Procmail file in my home directory (i.e. /.procmailrc) Though this might not be the case with you, the problem could be related to the one that I faced.

The solution? Removing SA using the Site Manager and then installing a copy manually (using SSH). It is not an ideal solution though, because as you read in one of the other threads, we don't have root so it is not possible to install it "at the same level" as the Site Manager does. However, I've discovered ways around all these issues and would be glad to assist you with them if it does turn out this is what is causing your e-mail problems. Besides a few minor gripes, I feel installing it on my own actually gave me a lot more control over it and I feel comfortable about messing around with it and it's "hidden" config files. I also feel as if I have total control over it - which is truly the case (all files are assigned to me, not root). As you may have noticed, SpamAssassin itself does not work as an executable if installed through the Site Manager (an annoying bug). That's just one of the problems that installing it on my own fixed.