PDA

View Full Version : Running site app OpenSSL causes "www" subdomain to



dave
09-10-2003, 12:11 PM
I incurred this strange problem while trying to get our SSL digital certificate working on WH 2.0. I found an application in the control panel under Site Applications / E-Commerce called OpenSSL. Running this application and renaming our certificates did fix the SSL problems. I found our 2 certificate files had been transfered to the new server and just needed renaming - for example from "pixelmetrics.crt" to "server.crt".

However, after doing this, all access to our our website using the "www" subdomain results in "This page cannot be displayed". So, http://www.pixelmetrics.com fails, but http://pixelmetrics.com works.

I checked the control panel under Domain Management and pixelmetrics.com, and the "www" subdomain seems to be correctly configured to /var/www/html.

Any ideas on how to fix this bad problem would be appreciated.

stonix
09-10-2003, 12:36 PM
Any body has idea how come OpenSSL certificate only effective for one day? How can make it lasting at for one year?

Alex Shi
Stonix.com

dave
09-10-2003, 12:41 PM
My earlier statement that the "www" subdomain fails isn't quite correct.

Some urls only work with "www", for example:
http://www.PixelMetrics.com/Test/Test.htm

Some urls only work WITHOUT "www":
http://PixelMetrics.com

Some URLs don't work either way:
http://www.PixelMetrics.com/CapWizLite/index.htm

It seems there's some deeper problem.

Anonymous
09-10-2003, 01:15 PM
hello dave,

i don't have much knowledge of it but i have the same problem with sub domains.

About 8 days ago my sub domains were allmost all down. Without the "www" they were visible on the screen. I created some alias sub domains domains called www.subdomain and that helped.

On the other hand quit often they are down or slow but afterwards up.
Every time i just sent my emails to Westhost when they are down again and the network status is o.k.

Anonymous
09-10-2003, 01:16 PM
hello dave,

i don't have much knowledge of it but i have the same problem with sub domains.

About 8 days ago my sub domains were allmost all down. Without the "www" they were visible on the screen. I created some alias sub domains domains called www.subdomain and that helped.

On the other hand quit often they are down or slow but afterwards up.
Every time i just sent my emails to Westhost when they are down again and the network status is o.k.

dave
09-10-2003, 09:52 PM
Today Chris Simiskey somehow fixed this problem. (Thanks, Chris!) All he said was:

"It would appear that there were problems with your SSL certificate not allowing the webserver to start."

ScottCole
09-12-2003, 07:14 PM
Looks like I have the same problem. How do I get my hands on a Chris Simiskey?

Scott

Thanks wildjokerdesign for your advice :D

wildjokerdesign
09-12-2003, 07:41 PM
Scott
Have you put in a ticket yet? Please don't be offended if you have. If you get a reply and ticket # or have one post it here.

Outstanding Issues - Site Down or E-mail Problems
http://forums.westhost.com/phpBB2/viewtopic.php?t=515
Make sure to hit postreply and not newtopic or your post may get baried in the forum.

They keep close watch on that topic. It may have been that Dave had PM'd Chris earlier on he was in the Fourm alot. Now that things are a little calmer it looks like Bevan and Mark are handeling the Forum... Not that they always have been.... If you post in the topic above I am sure they will catch it.

Tamara32
09-13-2003, 02:40 AM
Ummm...well...if he's married...I would ask his wife first!

Hang in there Chris...