PDA

View Full Version : E-mail Forwarding Question



web1x
09-08-2003, 11:08 PM
I use the catch all for my e-mail, but have a few addresses I would like to bounce. With ver 1.0, I could use dev/null to just delete e-mail to that address, and unknown_user to bounce e-mail to that address, but I can't seem to set it up in ver 2.0. It keeps telling me that these are not valid e-mail addresses. How can I effectively kill these few addresses without getting rid of the catch all? It would be preferable that these address generate a bounce message.

Thanks!
Robert

lreeder
09-09-2003, 08:17 AM
I just set up an alias (forward) to a bogus address like jjkh@ukjhsdfk.com. Works like a charm.

noclue
09-09-2003, 01:32 PM
i get hundreds of spam a day addressed to mydomain@mydomain.com. I don't use this address for anything and would like any mail to be bounced but obviously can't set up an alias for it.

Also, spammers are spoofing this address as the reply to and return path. This morning, so far, I've gotten over 600 spam - about twice what I got before the conversion to 2.0!

kitkat
09-09-2003, 01:53 PM
I'm confused about this as well.

I had set a postmaster@ as a catch-all, then deleted it because I had thousands of spam-emails in just a few days. I deleted the catch-all, and set the default email to postmaster with mailbox limited to 1 mb of email.

Obviously, I read the instructions wrong. I'm now getting returned mail - quota exceeded notices at mydomain@mydomain.com.

/kitkat

wildjokerdesign
09-09-2003, 04:50 PM
I had on the old account a user name that started getting alot of spam. so I had set up an autoresponder to bounce a message that the users was no longer available and a link to my conatact page... had to do that because a few folks did have the user name and I wanted them to be aware of the change.

In the new 2.0 that user shows up under E-mail/FTP Management > Users with the following setteings alias | User Account | Emabled | 1 | Enabled |1

When I click on that user name it opens up the Site Manager for that user.
Then under Email/FTP Management > Auto Responder is a the following
Enable Service | Enabled
Subject | Remove
Message | The above message I mentioned.

For now it is working although I do get an occasional userunkown returned that looks like it is because of that. This was how WH migrated it.

Back in the Site Mangager I have since deleted may Catch-All and added the users that I want to accept.

May not be a soulution for your case but thought I would put it out there.

noclue
09-09-2003, 05:19 PM
great idea lreeder except a great majority of these have my domain spoofed as either the return path and/or the reply to so I would just get the bounces also.

WDJ - not sure I understand. Can you set the autoresponder up somehow so it bounces messages?

Actually, I guess what I really need is somthing that would just dump them off the server without a bounce. So far today I am up to 764 spams and probably 40% of them came with spoofed addresses of my domain.

I did set up alias' for the good addresses and created a new catch-all and forwarded it to a yahoo account. That was a big help because their spam catcher seems to work far better than spam assassin did.

wildjokerdesign
09-09-2003, 05:36 PM
noclue,
No you can't set the autoresponder to bounce them that I know of. Now I do belive that you forward to a script but I do not know enough on that issue to say what the script would be. In the manual it suggest doing this for like unsubscribe aliases to auto romove from a list.

I can't find anything in any WH info that is like the old unknown_user option. Hopefully in the future they will add this as an automatic feature I think alot of folks could use it.

noclue
09-09-2003, 05:47 PM
thank WDJ, I remember seeing something in the manual about a script, but ... beyond my abilities right now.

wildjokerdesign
09-09-2003, 05:52 PM
Yes me too... maybe when things calm down I will dig for it and figure out something that works.

click-on-nik
09-09-2003, 07:30 PM
Wildjoker or anyone whose figured this out,
I have a question regarding my forwarding email aliases. I finally got them set up today, only now they don't work. I have the autoresponder installed with all of the email aliases enabled below it. On the Email/ftp page, I have the same emails listed under Users. I've configured their autoresponses, but I test them and they don't work either. Do you or anyone else have any ideas?

wildjokerdesign
09-09-2003, 09:37 PM
click-on-nik,

I only have a min but I wanted to respond. The autorespond I spoke of above was set by WestHost and I was trying to catch all the stuff they had did. I will go back and check to see if I missed anything.

The other thought I just had was I really had not fully tested it. I was assumeing it was working by some of the stuff I saw when I was looking at files VIA FTP. I did test once from one of my other accounts and it worked. The e-mial that has this set is shawn@wildjokerdesign.com and should return a message that gives a link to my contact page. It may not be working between all WestHost accounts which may be why it is hard for you to test your autoresponder. In the morning I will check it through a non-WestHost account and get back to this post.

Think I better mark to watch this post so I do not lose itl. :)

noclue
09-09-2003, 10:58 PM
just sent an email to the link in your last post and received, immediately, the link to you contact page. So this one works, at least for me. Just tried it from my ISP and it worked there, too.

wildjokerdesign
09-10-2003, 07:05 AM
Thanks noclue getting ready to get to the my computer with acces to all my accounts and files and will explore more as I had said. May take a bit seems some other issues have come up this morining.

Anonymous
09-10-2003, 07:25 AM
If you guys come up with any autoresponder fool proof ways or even random ideas, please please please let me know, ok?

wildjokerdesign
09-10-2003, 08:11 AM
My autoresponder is not the best choice although it functions. It really does not bounce back the e-mail wich I belive would be better but it was a quick fix. I had used that e-mail address at one time and did not want to lose any old contacts that where using it.

click-on-nik,
Are your autresponders still not working? From reading your post it sounds like you have the set up correct. Are there any that you would like us to test for you?

wildjokerdesign
09-10-2003, 09:06 AM
I am currently search through FAO's and documentation at both
http://www.redhat.com/ and http://httpd.apache.org/

So far I am not finding anything.

mkf
10-01-2003, 05:25 PM
I got it to work like this:

First, I set up an email address unknown_user@mysite.com, with both ftp and email access disabled.

To bounce mail addressed to bob@mysite.com, I alias bob@mysite.com to unknown_user@mysite.com

web1x
01-01-2004, 03:26 PM
I got it to work like this:

First, I set up an email address unknown_user@mysite.com, with both ftp and email access disabled.

To bounce mail addressed to bob@mysite.com, I alias bob@mysite.com to unknown_user@mysite.com

Good idea. It works great!

Is there any way to customize the bounce message? I would just like to add a line like this to the message:

Please see http://www.mysite.com/e-mail.html for a list of valid e-mail addresses for this domain.


Thanks!
Robert