PDA

View Full Version : Mail error 550 5.7.1 "Relaying Denied"



summitlake
09-08-2003, 06:59 PM
I receive mail fine at any of my converted WH2 mailboxes. When I reply to any of those emails, I usually get the following error and the mail is not sent:

error 550 5.7.1 <myrecipient@theirworld.net> "Relaying Denied"

That's on a reply, odds pretty close to 100%. On sending of newly created outgoing, odds areabout 50%-50%. Once an email is rejected once, it's "stuck" -- trying later doesn't seem to help.

Email client is PocoMail. Email and username are mymailbox@summitlake.com (example). Incoming and Outgoing Server are both summitlake.com. Have I missed an instruction? Anyone else having a similar problem?

PocoMail? Not the sharpest knife in the drawer, maybe, but you can check mail on the server without downloading. :!:

Alex

ccwebb
09-08-2003, 07:23 PM
I have had some unreliability with my outgoing mail. I use OE so the email parks in the outbox and on subsequent tries it will finally go.

I understand westhost is working on it. No idea of when it might be fixed.

Charlie

wildjokerdesign
09-08-2003, 08:38 PM
Ditto ccwebb many of us are haveing the same thing happen.

summitlake
09-08-2003, 10:29 PM
Nice to know WH is working on it. FYI, I had this problem quite some time ago with a Phoenix vacation ISP. WestHost had said some ISP's require you to send mail via their designated smtp, rather than through them to a third party like our host WestHost, which is "relaying" -- a big part of the spam mechanism. I called up Cox.net and they cheerfully admitted it; they don't want to be blacklisted as a relay site.

I set up an email account with Cox.net down there for my sendmail needs and that worked out fine.

I did the same up here today for my broadband ISP Comcast, and that seems to be working fine too on the WH2 converted mailboxes. You do have to be careful about giving out your reply-to with multiple WestHost accounts. I thought it odd all this "relay" stuff started right after the WH2 conversion.

daseinw
09-10-2003, 10:58 AM
I was having the same issue and seem to have resolved it.

I'm not sure how this works for different email clients, but I'm using Eudora. Basically, all I had to do to continue sending email is to right-click within the "Personalities" pane on the particular identity I use to send email...

Then, I made sure that the login name was correct and (this is the important part) enabled the "Allow Authentication" box.

What I believe happens is that whenever you attempt to send email from an alias on your account through your POP client, the server will first authenticate your main identity and then allow the email to be processed (others can feel free to correct me if I'm misunderstanding the mechanics) only if you are a valid account holder.

You get to send email as an alias from your account only after authentication with your real identity....which would seem to be a good thing since westhost will then be able to track anyone using the system to spam.

Hope this works for and helps some of you.

wildjokerdesign
09-10-2003, 11:33 AM
I corresponded with Chris on this Issue last night and ths morn and sent him some the error I was recieveing. I just did a test and no longer get the error. Hopefully they found the problem.

Beep
09-10-2003, 12:43 PM
I've had this problem all week. I seem to get the "Relaying denied" error only on certain email addresses. Some addresses that I know worked yesterday do not work now. :?

I've had a trouble ticket on it since last Saturday, but I understand that there are plenty of people with bigger problems than mine to solve. I feel a bit silly whining about it when at least I've got my web site up and I can finally read my incoming mail.

I'm using Outlook XP. If anyone finds a workaround I'd sure like to hear about it.

Thanks.

peter
09-10-2003, 03:48 PM
I am using Pine and I can't send emails at all. The error message is
"Mail not sent. Sending Error: 221 Closing connection."

Is there anything I can do changing the settings to resolve the
problem? Has anyone successfully sent any emails using Pine
under WH 2.0?

quicktrick
09-10-2003, 10:32 PM
1. Go into your outlook and edit your account settings for your email account. May sure you include your email address in the reply to field.
2. Use smtp authentication. Make sure you give it about 600+ on the time.

There are other tricks but they would be more of a techie thing. I am currently a westhost client but I have been a system admin for years and have worked with the same software you all are here for over a year. I hope this helps in your quest. quicktrick

Beep
09-11-2003, 02:10 PM
It is with guarded enthusiasm that I report fewer incidences of this problem today than yesterday. Dunno if I'm benefiting from the hard work of the Tech Team or if I'm just experiencing "self-healing software". Whatever. I'm just glad to be back online! :D

-Beep

Glocom
09-19-2003, 05:38 AM
Finally my replies are not bouncing back with "relaying denied." Here is exactly what I did in Outlook XP/2002 to stop this:

1) Tools -> Emails Accounts -> View or change email accounts

2) Select an email account then click on "Change"

3) Click the button that says "More Settings"

4) Click the tab type button that says "Outgoing Server"

5) Click the checkbox for "My outgoing server (SMTP) requires authentication, leave the next two radio buttons blank, and at the bottom of that box click the checkbox that says "Log onto incoming mail server before sending mail"

6) Repeat for each POP3 email account

Thanks to the other posters above who pointed me in this direction. What I did was not described above, so perhaps none of you were referring to Outlook 2002.

Glocom
09-19-2003, 08:57 AM
An update to my post above --
It seems that I decreased the problem, but some messages are still bouncing back. In addition, I just learned that my Worldmerge program doesn't work.

Any more suggestions on how to fix this problem for good would be appreciated. Of course, Westhost may be the one's who need to do this, when they get out of being neck deep in ...

Glocom
09-22-2003, 08:24 AM
Ok, here's a fix that REALLY worked. The problem, I think, is that Westhost updated to Sendmail 8.12.8 (I'm assuming). This version has relaying disabled by default. There are multiple fixes to allow relaying. Scroll down and see the links below for more details.

Here's what worked for me:

1. Get your computer's IP address (if you have a STATIC IP address, like for always on Internet connections). You can get your IP address at www.whatismyipaddress.com (you can log off, reboot, and check again to see if your IP address is static or always changing).

2. FTP to your account and go to: ETC\Mail

3. Find the "access" file, open it, and add:

xxx.xx.xxx.xx RELAY (the x's are your IP address)

4. For good measure, you can open your "relay-domains" file and add your IP address there (at the top, in the third spot I think)

That should enable relaying for any emails sent from your computer, IF YOU HAVE A STATIC IP ADDRESS. If you IP address changes every time you go online this won't work. For examle, if you are roaming (using a laptop to access email on the road), this won't work, but see the link below.

Note that when changing these files -- a) make a backup (e.g., rename to original rather than just replacing it), b) download and upload using ASCII mode, c) edit with Notepad.

These files are part of the SENDMAIL program. For lots more information about editing SENDMAIL files, go to www.sendmail.org/m4/readme.html then click on #15 "Anti-Spam Configuration Control" . Read that whole section and especially the part about the "Access Database".

Andy Gray
http://www.dial-abroad.org

silkpurse
09-22-2003, 10:11 AM
Finally my replies are not bouncing back with "relaying denied." Here is exactly what I did in Outlook XP/2002 to stop this:

1) Tools -> Emails Accounts -> View or change email accounts

2) Select an email account then click on "Change"

3) Click the button that says "More Settings"

4) Click the tab type button that says "Outgoing Server"

5) Click the checkbox for "My outgoing server (SMTP) requires authentication, leave the next two radio buttons blank, and at the bottom of that box click the checkbox that says "Log onto incoming mail server before sending mail"

6) Repeat for each POP3 email account

Thanks to the other posters above who pointed me in this direction. What I did was not described above, so perhaps none of you were referring to Outlook 2002.

This seems to have worked in Outlook 2003 (Beta) with minor changes as needed. Thanks Glocom!

summitlake
09-22-2003, 08:37 PM
I had lost track of this thread and never did anything on my end. I tried sending several test and real messages tonight from my "primary" mailbox. 100% success; no rejects. This agrees with what others are reporting.

After reading these posts I tried the suggestion of daseinw, who used Eudora. I use PocoMail, which is remarkably similar. It was a little late for this test, if I'm already getting sends by doing nothing. But using "Use Outgoing Server Authentication" (Login) does no harm, so I'll leave it.

Thanks

Glocom
10-05-2003, 09:38 AM
Note per my earlier suggestions:
If you DO NOT have a static IP address (which you probably don't, though it may just change every 24 hours), then you'll need to make an adjustment. Basically, you can still do all the above, but in your IP address find the part that never changes (e.g., the first 3 sets of numbers), and just use those. This isn't perfect, because someone who shares that part of your IP address could take advantage of you. However, it's much safer than lowering your security across the board to solve the relaying problem.

For those who can solve the relaying problem just by changing Outlook settings (using Authentication for example), that's great. But that doesn't seem to work for everyone.