PDA

View Full Version : Secure Server



ccwebb
09-06-2003, 08:34 AM
Prior to 2.0 our domain had a https path to a secure server.

After the domain migrated to 2.0 the same https path is still working (thank heavens).

The email and ftp username for the domain changed from "username" to "username@mydomain.com.

However, I still FTP access the secure files with just "username".

So I seemingly have a system that is 1/2 2.0 and 1/2 1.0.

My questions are:
Does this mean that the secure files have not yet migrated? Will they?
Or will we be required to transition our secure files over to the new method where I believe your secure and non-secure files exist together?

wildjokerdesign
09-06-2003, 09:14 AM
From the way I understand it all your old files are still where they are (for now) which is why your link to your secure files are working. They are pointed at the old location. That is why the old method of loging in with just username works. YOu are accessing the old files.

I think I would start to transitioning your secure files to the new method. I assume you have read about the new way... if not let me know and I will try to find that info and post a link to it here.

jholc
09-06-2003, 09:53 AM
I am also interested in the transition method. I have been able to continue ftp uploads in the same manner as pre-migration and my formmails still work there without any modification. However, I'm concerned that I will be left in the lurch when they pull the plug.

wildjokerdesign
09-06-2003, 09:56 AM
Yes it seems that formmail changes... there are a couple post on it... in short the workaround was that (I think) you point to FormMail.pl instead of formmail.pl

ccwebb
09-06-2003, 09:59 AM
However, I'm concerned that I will be left in the lurch when they pull the plug.

Judy:

Amen!

Charlie

jholc
09-06-2003, 10:03 AM
Yes, I saw the post on the formmail - it was in the cgiemail thread. But I don't remember where or if I saw the information on transition to the new ssl method. If you know, would you point us to it?

ccwebb
09-06-2003, 10:20 AM
Judy:

Check this out:

http://manual.westhost.com/part7.html#sharedssl

in 2.0 user's manual

Charlie

ccwebb
09-06-2003, 10:31 AM
Judy:

I just had a thought.

As I type, as a precaution, I am downloading all of my secure server files to my PC.

Better safe than sorry.

Charlie

wildjokerdesign
09-06-2003, 10:31 AM
I could not find the post but the bottom line was that you could make any page secure by linking to it with https instead of http . If you have links to images on that page you would have to linke to them with the https also to keep your users from seeing that "some things are unsecure" message as I understand it.

I will try to keep looking for the posted solution.

UPDATE

I knew there was more to it then just that... Now how did you find that in the manual I looked and looked :)

Thanks ccweb

jholc
09-06-2003, 11:43 AM
Charlie & WildJoker,
Thanks for the research. I've copied the files I'd had on secure.westhost into a directory on my domain. I had already installed FormMail through the Site Manager, so I modified one of my form files, pointing the post action to FormMail.Pl. My test form appears to work. I didn't have to modify any of the links because they were already full path names when they were on the shared server. I didn't see any secure-to-unsecure notices, but I should probably test it from a couple of different systems.

I just had pause on another concern... Went into Site Manager, forgetting that I'd already installed FormMail the other day. Was alarmed to see that my disk quota was exceeded. I swear the last time it was about 26%. Guess I'll have to submit to WH.

wildjokerdesign
09-06-2003, 12:06 PM
jholc... Yes do submit a ticket on the diskusage... It has happened on other accounts and they are aware of the overall problem and I think working on resoveing it.... looking at your case may help them... not to mention get it fixed faster.. :)

ekbart
09-07-2003, 06:10 PM
I tried running sharedSSL installer under the tools, and it gets a runtime error. And so my secure pages don't work.

edward de Jong
415-669-7010
magicmouse.com

TAiN
06-13-2006, 09:28 PM
I could not find the post but the bottom line was that you could make any page secure by linking to it with https instead of http.

I am interested in setting this up. Did you ever find the link? I can't find it in the guide or forum.

wildjokerdesign
06-14-2006, 08:02 AM
Tain,

This is a very old post from when WestHost was migrating from the old 1.0 to the new 2.0 system. Most all the information is now obsolete so to speak.

Not sure what part of the thread you had questions about but the manual does contain information on setting up Shared SSl and how to use it.
http://members.westhost.com/sm_sa_security_sharedssl.html

On the old system it used to be that all secure files had to be in a certain directory. Now you can secure any file on your site simply by using the secure path to that file. More information on this is in the manual.