View Full Version : File manager not working....

09-05-2003, 10:42 PM
The file manager is not working on my new account (domain: impenetrable.org). All I get is:

Error 403: Forbidden !

I checked the Apache Error log, and this is what it said:

Options ExecCGI is off in this directory: /var/www/html/fm/TinySpicy/TinySpicy.cgi

I added a script alias for the relevant directory and got the file manager working... sort of at least. All the images were broken (could not be loaded). Apart from that, it seems to be working correctly - it just looks hideous (without images). Checking the error_log file again:

file permissions deny server execution: /var/www/html/fm/corporate/images/TinySpicyLogoTop.gif

Says that for each of the images that were missing/that my browser tried to load.

Anyone else experience this?

09-05-2003, 10:47 PM
Interesting - I hadn't used the file manager yet. I didn't have the problems you reported, but... I do know that someone with westhost had probably accessed the file manager earlier (saw tinyspicy.cgi in my logs around the time they were looking into why a php script broke. So... they may have corrected it to get the job done? I did notice earlier today some _interesting_ behavior with the site manager, at first I couldn't login, then I could, but no stylesheet it seemed - I just got a plaintext version of everything - no functional javascript.... closed the browser, restarted and things were better, I suspect they may have been propagating some changes?


09-06-2003, 03:49 PM
Alright, I figured it out. For those of you that are having the problems that I was, here is how to fix it:

1. Log in to your 2.0 Site Manager (yourdomain.com/manager/)
2. Click Domain Management and then Web Aliases.
3. Click the New Alias button. Select Script Alias...
4. URL path:


5. Absolute path name:


6. Click Finish.
7. You can now use your File Manager by accessing it through the Site Manager, or going directly to yourdomain.com/fm/TinySpicy/TinySpicy.cgi

visible soul
09-07-2003, 07:59 AM
Thank you very much design64. I was having the same problem with accessing the file manager. No way would I have figured that out myself. It works now. :P

09-07-2003, 10:38 AM
My pleasure. I'm glad it helped.

09-10-2003, 02:08 PM
i was also wondering why the File Manager wasnt working and glad i stumbled across your post. got the alias in place but still being denied access--getting the message in error log you mentioned earlier:

"Options ExecCGI is off in this directory: /var/www/html/fm/TinySpicy/TinySpicy.cgi"

any more suggestions--thanks in advance,

09-10-2003, 02:20 PM
Hi John,

The first thing that comes to mind is that you may have done something incorrectly. Did you follow the steps exactly and carefully? Made sure you added a script alias and not just a "normal" alias? Typed the directory names/paths carefully? If yes in all cases, you should probably submit a support request to WestHost.

09-11-2003, 09:26 AM
Thanks Fayez,

I will check through it all (again) and enter a support request if still no success. One related question though, are you logging in to the File Manager as "user@domain.com" or just "user". Either way seems to work when I login to the Site Manager but I thought that the manual said to use "user@domain.com"--I have tried both. Thanks again for your help.


09-11-2003, 09:48 AM

I use just the username to log in and had not tired the other combination. You are correct that the manual say's to use the username@yourdomain.com combination.

09-11-2003, 01:44 PM
You're welcome John - let us know how it goes.

I use just username for SSH and all web related user authentication. E-mail and FTP I use the full username@domainname.com...

09-11-2003, 10:16 PM
Doh! I had created a regular alias rather than a script alias--of course that wouldnt fix a script permission error. Thanks for the continued help. Feeling dumb but happy now.