View Full Version : Some SSH-related problems (WestHost 2.0)

09-05-2003, 06:19 PM
I just had a new account set up (I also still have an old account that is on 1.0). I have a couple of problems with it (new account) though, and was wondering if other people on 2.0 (migrated or otherwise) that use SSH noticed these too:

1. There's a problem with some files assigned to user root and not me - this obviously means that I cannot modify these files, which is fine for most of the files set as this, but not for something like .bashrc which I would like to customize/add aliases, etc. to. Anyone else able to modify their .bashrc?

2. SpamAssassin does not seem to be installed correctly:

$ spamassassin --help
sh: ./spamassassin: /usr/local/perl/bin/perl: bad interpreter: Permission denied

It is only available in the / (root) directory, it is an actual file (in /) and is assigned to root. I cannot "execute" it anywhere else. I can open it with Pico too, but obviously cannot edit it. I have already tried changing the true/false to 1/0 in local.cf. Perl is installed and seems to be functioning properly.

3. I know this may be a little petty, but it worked in 1.0: the HOME, END, DELETE, etc. keys don't work anymore! I know DELETE never worked at the command prompt, but it did in Pico - not anymore though! HOME and END did, however, work at the command prompt. I make a lot of mistakes when I type so use of these keys, to me, is essential.

Anyone else?

09-05-2003, 06:52 PM
I noticed the home/end keys - a little annoying.... I haven't noticed the spamassassin issue - but I did notice files not owned by me - I hadn't had a chance to look at the .bashrc file.

One thing that I'm REALLY missing is scp !!!!!
And for that matter I'd love to have the ability to have a secondary user login. That seems to be a technical limitation... Maybe there will be a workaround for that.


09-10-2003, 05:55 AM
Problem/bug 1 - .bashrc not "editable" has been fixed. WestHost even added a "restart" alias ;) Great job.

I found something to kind of alleviate the stress of bad typing at the command prompt and no Home and End keys: Control-W deletes the "rightmost word". It helps, but I still miss those keys!

SpamAssassin bug still not fixed, though...

09-11-2003, 03:40 AM
My ~/.bashrc is owned by root, but is a link to /.bashrc, which is owned by user, so should be editable.

You can copy scp from an old installation and add it in to the new installation. It works.

On a similar subject, does anyone know where to put (what would normally be) my ~/.ssh directory so that ssh can find it?

09-11-2003, 04:28 AM
It seems that the home directory for root under 2.0 is actually / and not /home/username/ - have you tried placing it in /?

09-11-2003, 05:00 AM
You mean me?
Yup. Been there, done that....

09-11-2003, 06:40 PM
the HOME, END, DELETE, etc. keys don't work anymore!

Home: Ctrl-A
End: Ctrl-E
Delete: Ctrl-D

Having had to use a telnet session over ancient terminal emulators, I had to learn these and the cursor equivalents (Ctrl-B, Ctrl-F, Ctrl-P, and Ctrl-N, if you're curious).


09-11-2003, 06:50 PM
Brilliant, thanks dreamwolf!

You wouldn't happen to know how I could bind those to the respective keys using Putty or a Bash profile (or whatever), would you? :lol:

09-11-2003, 07:00 PM
I don't know if it's possible, but I'll look into it and post if I find anything (or fail to find anything, for that matter).

FYI, I've been a Linux user since '98. (That doesn't mean I'm good, just that I'm comfortable with it. ;) )


09-11-2003, 07:09 PM
That'd be great, thanks. I've never had the pleasure of playing with Linux... I would, but some of my favourite programs don't support it (and I am lazy). The only "contact" I have with it is when I SSH into my WestHost account - and I love it ;)

09-11-2003, 08:44 PM
Well, if you got another computer somewhere collecting dust (I have about 7) I'd suggest you to grab a distro and get started. I like Debian (http://www.debian.org), but that's one for people that don't like software setting up drivers and such. In other words, I had to figure out what driver to load for my sound card, etc. on my own. I think Mandrake (http://www.mandrake.com) is a pretty good distro for newbies. :) There is also another thread on this forum about this. You should check that out.

09-11-2003, 09:04 PM
Thanks for the info. I'll keep it in mind :)

09-11-2003, 11:24 PM
I read quite a lot of documentation and struggled with many different methods (decimal codes, hex codes, escape codes, name values, single quotes, double quotes, no quotes...). Particularly troubling was that I kept disabling my keys by binding them to beginning-of-line or delete-char! (I find it very hard to do much without "\" or "e.")

Add the following to the end of your .bashrc (which should be available in whatever directory you're in after login):

bind \"\\e[1~\":beginning-of-line
bind \"\\e[3~\":delete-char
bind \"\\e[4~\":end-of-line
Hope this helps (it should - it works for me)!

Oh, and the best way I've found to try out Linux is with one of the bootable self-contained CD distros. Try Gnoppix (http://www.gnoppix.org/index.html) or Knoppix (http://www.knopper.net/knoppix/). No installation necessary!


09-12-2003, 11:29 AM
Holy $h1t!!!

I could kiss you, dreamwolf! You're the man.

Thank you very, very much. If you ever need anything... :)