PDA

View Full Version : cgiemail



Anonymous
09-03-2003, 10:11 AM
I have been using cgiemail successfully. Now with 2.0 its broke!! I get an internal server error. Just changing the location of the cgi-bin to www/cgi-bin doesn't fix the problem. Is anyone else getting cgiemail to work? I have sent several messages to westhost about various problems and have heard nothing so I need to get help somewhere else. Thanks.

lreeder
09-03-2003, 10:14 AM
Usually an internal server error is permissions related. You may just need to reset the permissions to 755.

Anonymous
09-03-2003, 01:03 PM
Dottie, I don't know what happened (it was not permissions because I tried that), but Westhost solved it (only that! Not the Mysql issue nor search.cgi script which I'm still waiting for).

Anonymous
09-03-2003, 02:47 PM
What do you mean by Westhost solved it? Are you cgiemail forms working now? My still are not working.

jholc
09-03-2003, 05:14 PM
I also had a cgiemail form that went belly-up. I tried changing it to formmail. Then installed the formmail app through site manager. That didn't work either. I finally moved the formmail form onto the shared SSL server where I had other formmail forms already and that worked.

At least for now... Are they going to convert the SSL server, too? For now I can still ftp into secure.westhost with my old log in.

Anonymous
09-03-2003, 07:14 PM
Yes, they solved the cgiemail issue on my site (lucky me because all my forms were based on it).

Unfortunately the other things are still not solved... anyway I can survive at least with cgiemail.

Regards,
Diego.

WestHost - BErickson
09-03-2003, 11:23 PM
Everyone,

If you are having trouble with forms (mainly internal server errors) and are using "cgiemail", then you need a new version (recompiled) of cgiemail. One can be obtained here: http://www.splitbrain.net/cgiemail

We are going to fix this for everyone soon, but for those that can't wait, either:
- swap the file for the new one
- tell us to swap it for you
- wait for us to swap it for everyone

Hope this helps,

Anonymous
09-04-2003, 08:40 AM
Do you have the Mysql.pm file somewhere?

gethipp
09-04-2003, 09:07 AM
The form to email funcitonality has changed dramatically. It's no longer formmail.cgi, but is now FormMail.pl (note the caps). The directory to point to is domain.com/cgi-bin/formmail/FormMail.pl

You'll have to request the install of FormMail.pl through your Site Manager. Once it's installed, point to the directory above from your HTML form.

It's case sensitive, so make sure to name the FormMail.pl correctly.

Hope this helps.

Susie
www.GetHipp.com

chill03
09-04-2003, 10:19 AM
Everyone,

If you are having trouble with forms (mainly internal server errors) and are using "cgiemail", then you need a new version (recompiled) of cgiemail. One can be obtained here: http://www.splitbrain.net/cgiemail



Hi,
I swapped the cgiemail with the new one and instead of an internal server error I get the following error:
Forbidden
You don't have permission to access /cgi-bin/cgiemail/order.txt on this server

The permissions for cgiemail and the order.txt file are both 755, is there anything else I should try?

Thanks for your help,
Chris

Anonymous
09-04-2003, 01:07 PM
But the order.txt is on the same directory that index.html ?

Because usually it is located on the /forms/blaba.txt...

Anonymous
09-04-2003, 01:10 PM
Also there's an .htaccess file which establishes which directories you can read (or files I think). Try changing something there

Anonymous
09-04-2003, 08:36 PM
Ok, Bevan. Please place the new cgiemail on my website: supportyou.com. I don't know how else to ask since I can't get through on the phone and I don't get tickets from the tech support form so I don't know whether you are getting it or not. Certainly, even though I have labelled the cgiemail problem as an emergency, I haven't heard anything. I have temporarily replaced the forms with formmail forms but they don't do what I need. I really need the cgiemail capability back!

Dottie Elliott

Bevan Erickson said:
Everyone,

If you are having trouble with forms (mainly internal server errors) and are using "cgiemail", then you need a new version (recompiled) of cgiemail. One can be obtained here: http://www.splitbrain.net/cgiemail

We are going to fix this for everyone soon, but for those that can't wait, either:
- swap the file for the new one
- tell us to swap it for you
- wait for us to swap it for everyone

Hope this helps,
_________________
Bevan Erickson
WestHost Inc.
Phone: 1-800-222-2165
FAX: 435-755-3449

Anonymous
09-06-2003, 10:03 AM
If I replace the cgiemail with the newly tweaked version will it work with Westhost 1.0? One of the sites that we maintain hasn't been moved to 2.o and it would be nice to make a smoooooth transition.

thanks

wildjokerdesign
09-06-2003, 10:09 AM
I belive that when they start updateing again they will have fixed the problem.... you could try using the new cgiemail on the old site but not sure that is would be the best idea... If you do make sure you backup on your own computer so you can restore if you run into problems.

chill03
09-07-2003, 08:53 AM
Bevan Erickson said:
Everyone,

If you are having trouble with forms (mainly internal server errors) and are using "cgiemail", then you need a new version (recompiled) of cgiemail. One can be obtained here: http://www.splitbrain.net/cgiemail

We are going to fix this for everyone soon, but for those that can't wait, either:
- swap the file for the new one
- tell us to swap it for you
- wait for us to swap it for everyone

Hope this helps,
_________________
Bevan Erickson
WestHost Inc.
Phone: 1-800-222-2165
FAX: 435-755-3449

I don't know if Westhost ever swapped the cgiemail or if the swap I did worked but cgiemail was working from Thursday-Sat, now I'm getting the following error when I submit a form:
hash map "Alias0": unsafe map file /etc/mail/aliases.db: Permission denied

Is anyone else's cgiemail working? Any suggestions, changing the permissions for etc/mail folder and aliases.db files did not work.

See ticket#75294 (discarded by JStockdale?) or #77604 (hasn't been looked at yet placed 4 days ago) for this and other 2.0 problems I'm having.

Thanks for your help,
Chris

wizardofaz
09-09-2003, 06:24 PM
I am currently using cgiemail from a secure form, and the form page is on the OLD shared SSL server. It still works, but presumably will go away someday soon. I invoke cgiemail like this:
https://secure.westhost.com/cgi-bin/cgiemail/secure/artesaniaalmazan/securehtml/order.txt
I am willing to move my secure pages to the new style of doing shared SSL described in the 2.0 manual, but I don't know what the appropriate https path to cgiemail is in the new scheme. Anybody got an idea?

Thanks - Bill

erich
10-30-2003, 01:49 PM
I just got cgiemail to work on a WestHost 2.0 account.

The stumbling block that I had was the fact that I did not have FTP access turned on for the e-mail accounts that the forms were sending to.

So, if you are receiving error code 500, exit 70, make sure you have the FTP access turned on for the POP account you are sending to.

Regards,

Erich Russ

jalal
10-30-2003, 02:29 PM
Although you can immediately turn off FTP access if you don't need it. Turning it on creates the home directory for that user, turningit off leaves the directory there, which is what cgiemail is looking for.