PDA

View Full Version : setting permissions with file manager



daltonlp
09-02-2003, 02:05 PM
The old file manager had a (somewhat non-intuitive) method for setting permissions.

The westhost 2.0 file manager appears to have no way to change a file's permissions (though I have to say, the overall design seems better than the old one).

Am I missing something?

- Lloyd

FZ
09-02-2003, 03:33 PM
Have a look at http://manual.westhost.com/part4.html#filemanager The "Perm's" column shows the permissions. I can understand how that can be somewhat daunting if you are not familiar with CHMOD/permissions. Just search Google for "CHMOD tutorial" or something similar.

daltonlp
09-02-2003, 03:48 PM
I understand how file permissions work, thanks.

I'm afraid the screenshot in the manual doesn't match reality. It appears to be from a different version or a different application altogether. Here's a screenshot of the file manager interface.

http://iss.westhost.com/ss1.gif

Notice that the permissions column is not named "perms". The permissions descriptions aren't links either.

FZ
09-02-2003, 04:04 PM
Thanks for the screenshot.

My bad. You could always "Execute a shell command" and do a CHMOD manually (or just use SSH) if you really need to.

daltonlp
09-02-2003, 04:17 PM
I tried using chmod with the shell command. It didn't work. I tried both:

chmod 755 index.cgi

and

chmod 755 /usr/home/iss1/daltonlp/scouts/index.cgi

Neither appeared to have any effect (the area under "result" was blank).

I tried some gibberish:

chmod auhkaushdkuh

just to see if I'd get an error back. The results (none) were the same as when I tried the chmod commands. I'm using firebird .6.1

I know ssh works, but if I'm behind a firewall, I can't use ssh.

So it looks like there are two problems. No way to change permissions, and a broken shell command interface.

- Lloyd

FZ
09-02-2003, 04:31 PM
Have you tried it using the "alternative format" (e.g. CHMOD og=rw)?

daltonlp
09-02-2003, 10:31 PM
No, I didn't try the alternative format.

I quit trying after realizing that the command line interface never returned results, regardless of whether the command was valid or not.

Have you tried the file manager command line interface?

- Lloyd

FZ
09-03-2003, 11:43 AM
The fact that it gives you no output is just plain silly (poor design). And yes, I have tried it - only during the Beta test though (3rd week of July). Obviously, there have been a couple of changes since then, because, as you pointed out, the actual File Manager looks nothing like the one in the screenshots in the manual (which is the one I got to play with).

You could easily make your own "command line interface" using PHP though (and have it output the results to your browser). Have a look at this (same concept): http://forums.westhost.com/phpBB2/viewtopic.php?t=288 I do agree that you should not have to resort to re-coding something that WestHost has provided you with - their version is supposed to work as intended. We should point this out to WestHost.

noclue
09-03-2003, 01:05 PM
alread pointed it out a few days ago. I don't know Php so, I'm stuck.

FZ
09-03-2003, 02:03 PM
If you tell me what exactly it is you want it to do, I would not mind coming up with something for you. If all you want to do is CHMOD, it will probably take about 20 seconds to do.

noclue
09-03-2003, 02:21 PM
design64, what a genours gesture. thank you!

But, my site was down with a 500 after I called for support about a custom 403 not working. After a phone call I discovered the reason, not my fault, a tech moved a file from old IP to new one and my site was down for 8 hours before I discovered it.

After that I thought everything was ok so I tried to add an email account and an alias and site went 500, again. This time tech support said it was due to Norton and I would need to disable Norton to use the site manager. Not willing to do that since I'm on ADSL and have hack attacks to ports almost constantly.

That said, I'm fearful to do anything again because, at least, my site and email appear to be working.

What I wanted to do is change all my passwords (know this isn't CHMOD and I could do it in the site manager - just scared to touch anything until WH get this all fixed) and I want to check to see if the directories I had passworded in the old version are still passworded and, if not, give them a new password.

noclue
09-03-2003, 03:09 PM
sorry, I said passwords for directories and I meant permissions. This has been a long day, uhm ... week

wildjokerdesign
09-03-2003, 06:26 PM
Dont' know if this will help you but I have never used the WestHost File Manager to upload to my site and work with directories and such.

I use WsFTP- Pro it cost $39.95 but I like the program and it makes things alot simpler for me. Here is the link http://www.ipswitch.com/Products/WS_FTP/index.html

I have heard of some free programs out there and infact at one time Ws_FTP had a free version but could not find it on thier site now.... I didn't dig very deep you may be able to find it.

noclue
09-03-2003, 06:39 PM
thanks wildjokerdesignm but I don't use the file manager for those things either, also use ws-ftp. But if there is a way to set permissions in ws-ftp, I don't know how, although I am not using the Pro.

ajparker
09-03-2003, 06:45 PM
Here's a site on changing permissions with ws_ftp http://www2.hostings.com/manual/sectione/change_wsftp.htm
that may help.

Avery

FZ
09-03-2003, 06:50 PM
noclue,

I'm sorry - I'm totally confused as to what you want to do - just simply CHMOD directories and files?

You can set permissions in WS FTP (non-pro) as well. Just right click the file and look for CHMOD (or "Properties" - might be in there). It might not be under the "main" context menu - it might be under "FTP commands" or something similar. If it is not, just look for the option to execute a custom FTP command (I think it is called "quote") and just do the CHMOD manually.

My offer to code some PHP for you still stands :)

noclue
09-03-2003, 06:57 PM
doh! see what happens when you've been using a program forever and before you knew anything? you get so much like one of pavlov's dogs that you never look around. Thank you, ajparker - a "new" tool to use and a reminder not to go blindly running through tunnels :D

noclue
09-03-2003, 09:34 PM
Fayez,

Thank you again, but since discovering I can use ws-ftp to set permissions, I'm ok. I am feeling rather dumb for not knowing about it, though :oops: