PDA

View Full Version : MySql Problem



woome
08-19-2003, 02:30 PM
I am trying to setup a website and I installed all the mysql and php addons through the admin panel. I have also successfully uploaded my sql table to it. My problem is that when I go to the website and put in my information for the mysql table its not seeing it. What exactly are parameters I need.

These are what I need for my website

Your database host (it may be an IP address): localhost ?
Your database username: is this my westhost username?
Your database password: is this my westhost password or the one that you choose when installing mysql? I have tried it with both to no avail
Database name: this is the name of the database that I created correct?

Any help would be greatly appreciated.

Perhaps the system needs time to propogate the information. I just installed everything and uploaded the table but maybe it takes time for the system to access it? This is the only thing that I can think.

FZ
08-19-2003, 03:27 PM
Only applicable if you are using WestHost 2.0 (it sounds like you are)... Also, since you didn't give any details as to what the error message, etc. was, I'm assuming you just can't get access to your database (incorrect username/pass?).

Being part of the WestHost 2.0 Beta Test Program, I found I had the same problem. I spent many frustrating hours to no avail, until I finally discovered that the mySQL username you have to use is actually "root" (yes, r-o-o-t, no quotes) and not your WestHost username (assuming they have not fixed this problem). The password should be the one you chose while installing mySQL, host should be localhost, and database name the name of the database you created.

Hope this helps :)

woome
08-19-2003, 08:06 PM
Oh wow that is crazy. Do you still have to use root for the username even now?

woome
08-19-2003, 08:09 PM
hey thanks a bunch that really helped me out. I can't believe that you have to use root and they don't tell you that. It was driving me crazy!

FZ
08-20-2003, 09:01 AM
woome,

You're welcome - glad I could help. I did point out to the people running the Beta program that they should mention this in documentation, and I was told that they would... Either they forgot, or they're still working on it ;)

dmenese
09-01-2003, 06:07 PM
Since Westhost 2.0 (second parts are never good!) on my perl scripts the "use Mysql;" gives me this error when testing with Perl compiler:

"Can't locate Mysql.pm in @INC "

Anyone knows how can I fix it? I tried looking for Mysql.pm but couldn't find it. I tried posting ticket #69925 and #73054... no solution since friday.

Regards,
Diego.

woome
09-01-2003, 08:33 PM
Great now even using the root as the username doesn't work. These servers are seriously screwed up. Does anybody know if they have changed the mysql database information.

BeaverheadRiver
09-01-2003, 10:44 PM
"Can't locate Mysql.pm in @INC "

Anyone knows how can I fix it? I tried looking for Mysql.pm but couldn't find it. I tried posting ticket #69925 and #73054... no solution since friday.


I was having a similar problem and one of the techs resolved it by installing the perl mySQL database library. Don't know why this wasn't standard/automatic.

However, if you have access to Site Manager, I think you can add those in under the Add On programs section.

dmenese
09-09-2003, 07:17 AM
Yes. Westhost finally solved it. But it cannot be solved from Site Manager.

sipages
11-19-2003, 09:17 PM
Thanks FZ. I had it narrowed down to a password problem but spent 4+ hours trying every combination I have ever used. Finally used root -- and it worked. You saved me from putting my fist through my monitor (it was getting close) !!!
:D

FZ
11-19-2003, 09:28 PM
Cool :) You might want to install Phpmyadmin via your Site Manager and then add non-root username(s) with limited access/privileges (increased security). That might also be better to do if you have too many scripts you'd need to modify to use "root" as the username.