PDA

View Full Version : Some Joomla sites are slowing to a crawl - front and back ends



cgmsys
01-04-2013, 06:09 PM
Over the last two or three weeks, I'm seeing that some of our joomla sites are slowing to a crawl. I've been back and forth with tech support and they indicated that 'Processes are using up the CPU". However, these sites are low traffic. most of the time, there is only one or two guests on at a time.

Here are some of the particulars.

- Our frontpage sites seem to be OK.
- Some of the sites we havent' done much with and are running on j 1.5 seem to be OK.
- Some of the J 2.5.x sites are OK. These are sites we have not been working with.
- Each site has it's own fairly strong PW.
- Some of the extensions we are running are securitycheck, JCH Optomize, admin tools, admin exile, I've looked to see if there was any common denominator among the sites but could not find any.
- Some of the sites are on a reseller account that we use. On that account, some of the j 2.5.x sites are Ok and others are slow.
- One site that is horribly slow is a site for a client. I have to get this resolved soon as the decrease in traffic from the slow site is killing them.
- One site is on shared hosting that we purchased just for that site.
- Symptoms are that the front and back end becomes very sluggish. Occasionally a page will load quickly but the overall experience is horrible.
- We also measured the performance with webpagetest.org and pingdom.com. Occasionally pingdom will report decent speeds while the experience at our end is slow.
- We have tried from other locations to rule out any issues at our end.
- The situation seems to be getting worse with no sign of getting better.
- It ****Seems*** that the problem is worse late at night
- I've pretty much ruled out third party ads as the one slow client site is a business with no ads and very few outgoing links.
- The sites with problems are on at least 3 different servers. THe problem seems to be the same on all of them.


A couple of possibilities I've considered
- Bad extensions - I've disabled any extensions I could but that didn't improve performance.
- Congestion on the westhost end of the net.
- A bug in a recent update of sql, joomla or one of the extensions (See above about testing by disabling)
- If I am correct, J 2.5.x uses mysqli instead of mysql. Not sure if that could be a problem or not.
- Misconfigured .htacess - I haven't made any recent changes and the .htaccess is pretty much the same throughout the sites.
- Some of the sites were previously frontpage sites. I remember that there was a pretty convoluted process that had to be done to enable sites on a reseller account to work using Frontpage. I forget exactly what that process was and will look it up. However, I think that is not a likely cause.


I'd appreciate any thoughts from anyone about the performance of their joomla sites and if you have any ideas as to how to get the speed back to normal. This almost cost me a major client the other day and my advertising sites are falling off the SEO rankings thanks to bounces.

two of the sites that are causing problems are

www.bucksviews.com
www.bcsbc.com

However, if you go to the following sites they seem ok

www.capemayviews.com - a frontpage site
www.rometravelviews.com - a joomla site that we haven't played with for a while.




chris

wildjokerdesign
01-05-2013, 05:50 AM
Hard nut to crack. The only thing I can think is to examine the logs for the periods where they do seem to slow down to see what is happening traffic wise at that time. I had an issue once that related to search engine spiders hitting a photo gallery. Perhaps something similar is happening.

Of course make sure that your databases are optimized and that all extensions are up to date, but it sounds like you may have already thought of that.

Have you thought of perhaps dropping Joomla and going old school HTML with some of these sites. For example the BCSBC site looks to be a pretty simple Home page with three other pages. I could not actually get the other pages to load this morning just the front page. It looks like there is a lot of JavaScript being loaded for the front page that may not be needed. Remember if it is guest viewing the site or spiders they are having to also load these files from your site with each hit not to mention the images themselves.


.

cgmsys
01-07-2013, 12:00 PM
@wildjoker - Thanks for the input. I think I found the problem. It is an interaction between the SEO extension I"m using and the latest PHP upgrade. The SEO extension is a paid extension and it doesn't auto upgrade. You need to go out and get the latest. Even at that, I had to completely uninstall the previous version and then reinstall the latest version. I believe there was also some interaction with another extension as well.

That fixes the imnnediate problem. Now I need to work on the images, template and other pieces to get the load times down as far as possible.



thanks again.

wildjokerdesign
01-08-2013, 06:53 AM
Glad you found it! Also pleased you came back and let us know about it. It can be really hard to track down things like this. Keeping software and programs like joomla can be a real pain but is essential to keeping a site running smoothly.