View Full Version : Using Zope/Plone

03-30-2010, 06:42 AM
Hi All,
I am considering using Plone for a new domain, i.e. in addition to my current site.

Are you using, or have you used, Plone on your VPS?

If so, what is/was your experience in using Plone?

Any comments/suggestions/advice shall be gratefully received!:)

Here's to Your Success!!!:)

Very best regards,

03-30-2010, 07:40 AM
I have not installed or run Plone before on a WH 3.0 account, but I have set up Zope on an account before. All though it has been awhile since I did that I don't recall any real problems that I ran into installing Zope. You well need to install the GNU Compiler Collection via Site Manager before you start install of both.

The recommended 512 MB or more RAM per Plone site might be an issue for Plone. It seems I remember that on WH 3.0 our share of RAM is a bit lower then that. The minimum is 256 MB RAM so you might be ok depending on what add on services you want to add to Plone.

You also mention that you want this to run a second domain on your site. That may take some fancy foot work to get running since the idea is that all normal Apache traffic gets run through Plone. It may not be a problem but something to keep in mind. Also don't forget your other site is going to be using some of that available RAM also.

03-30-2010, 08:33 AM
Hi Shawn,
Many thanks for your reply.

You say :
"You well need to install the GNU Compiler Collection via Site Manager before you start install of both. "

One of the problems I've always had with my WestHost has been that the Install Box has never shown the 'Install' button so I've always had to ask WestHost to do it for me! :-(

You also rightly point out :
"Also don't forget your other site is going to be using some of that available RAM also."

That is the other reason I've posted this Thread - to try to find out if I will need to try to have more RAM added.

So far I am staying with WH3 rather than risking CP.

Any further help/advice will be greatly appreciated!

Many thanks Shawn. :-))

Here's to YOUR Success!!! :-)

Very best regards,

03-30-2010, 10:20 AM

I decided to give Zope/Plone a try out. :) Just finished up installing on my testing site. Using their Unified Installer worked great. It does take some time to install. It well install it into /usr/home/[username]/Plone.

I was following these instructions here: http://plone.org/documentation/kb/installing-plone-3-with-the-unified-installer It well install as the user for your account since we do not have root access. The only concern I have with that is they recommend installing as root for production servers. May not be that big of a deal but wanted to mention that. I used the ZEO Installation command.

BTW: Once you have GNU installed on an account you should not have to install it again. Not sure I understand your comments about not having the Install button. Do you have this issue with other things in Site Manager > Site Applications > Install & Manage?

It does seem to use quite a bit of RAM. I am not the best at analyzing this but when I run ps aux in Shell here is the output for firs the Zope/Plone site and then another site I run via HTTPD and MySQL:

PLONE 8047 0.0 0.0 2784 1260 ? S Mar13 0:00 /bin/sh /usr/loca
PLONE 8096 0.0 0.1 34136 4748 ? Sl Mar13 0:00 /usr/local/mysql/
PLONE 8120 0.0 0.5 41636 22516 ? Ss Mar13 0:03 /usr/sbin/httpd
PLONE 23937 0.0 0.5 41868 20140 ? S Mar19 0:00 /usr/sbin/httpd
PLONE 32722 0.0 0.4 41772 19032 ? S Mar27 0:00 /usr/sbin/httpd
PLONE 5832 0.0 0.1 10508 5560 ? SNs 07:19 0:00 /home/PLONE/Pl
PLONE 5833 0.2 0.2 23460 9868 ? SNl 07:19 0:10 /home/PLONE/Pl
PLONE 6929 0.0 0.1 9212 4284 ? SNs 07:21 0:00 /home/PLONE/Pl
PLONE 6931 2.0 2.6 159468 103780 ? SNl 07:21 1:14 /home/PLONE/Pl
PLONE 7019 0.0 0.1 10904 4284 ? SNs 07:21 0:00 /home/PLONE/Pl
PLONE 7020 1.0 2.1 109600 84064 ? SNl 07:21 0:39 /home/PLONE/Pl
PLONE 14497 1.0 0.0 2376 1428 ? SNs 08:21 0:00 -sh
PLONE 14524 0.0 0.0 3460 944 ? RN+ 08:21 0:00 ps aux

REGSITE 14497 0.0 0.0 4144 1260 ? S Mar17 0:00 /bin/sh /usr/local/mysql/bin/mysqld_safe --datad
REGSITE 14575 1.7 0.4 45400 33516 ? Sl Mar17 312:16 /usr/local/mysql/bin/mysqld --basedir=/usr/local
REGSITE 14911 0.0 0.2 69836 19204 ? Ss Mar17 2:34 /usr/sbin/httpd
REGSITE 5351 0.0 0.0 4288 1424 ? Ss 08:18 0:00 -sh
REGSITE 7899 0.3 0.3 71312 30200 ? S 08:23 0:01 /usr/sbin/httpd
REGSITE 8574 0.5 0.3 71344 27372 ? S 08:24 0:01 /usr/sbin/httpd
REGSITE 10965 0.0 0.0 3984 940 ? R+ 08:28 0:00 ps aux

It seems I remember a forum post about server resource consumption and when you started getting above the 1.0 mark that it was not the best situation. With that being said, you might be able optimize the installation in some way by digging through the documentation at Plone. Seems I do remember seeing a topic on that.

Also you are going to want to have a look at this page: http://plone.org/documentation/kb/plone-with-apache You need to really read this page closely. I missed the "Your Plone site is /mysite inside the Zope." part. With the installer it sets up your site by default in /Plone. :) I thought I needed to use the ID that is mentioned later in the page in httpd.conf. BTW I did with set up with a second domain I added to my test account so it should work fine for you. It also keeps the original domain as is.

I do like the flow of Plone. Pretty easy to understand right from the start when you log in. Adding content is pretty easy and straight forward.

Remember I am as new to this as you are. Everything I know comes direct from reading the Documentation at their site.