View Full Version : ejabberd install error

10-29-2009, 01:14 AM
I am in the process of installing ejabberd on my VPS. I have been successful so far, however there's an error related to Erlang. When I run this command:

./ejabberdctl live

I get this error:

"Protocol: ~p: register error: ~p~n",

The error is documented here: http://www.ejabberd.im/node/3709

This page says to fix the error the following commands must be run as the root:

nattribute --set --nid virtual_system_name --flag ~single_ip
echo "~single_ip" > /etc/vservers/virtual_system_name/nflags

Is there any way that I can fix this myself? Are there any other solutions to this problem? If not, I think I may have to ask Westhost to do it, and I'm trying to avoid additional expense.

Thank you =8^)
Sharon Murphy

10-29-2009, 04:30 AM
We do not have root access only root like access. Have you tried running the command? Sometimes even though a documentation says you need to run something as root it will still work. If the command gives an error about not being root then you would need to contact WestHost.