PDA

View Full Version : Perl, CPAN and Movable Type 4.x



lobstershell
08-03-2009, 08:56 PM
My Movable Type install stopped working (500 error) after I upgraded to Perl 5.8.8. I was/am using additional Perl modules using CPAN and the /perl5lib directory mentioned in another post.

And after running some CPAN updates, I now get this error:

Got an error: Publish error in template 'error.tmpl': Unknown tag found: setvarblock
at mt.cgi, whereas previously the log entry linked with the 500 error was something like:

Premature end of script headers: mt.cgi, referer: http://www.lobstershell.com/mt/mt.cgi

MovableType does not seem to recognize the perl5lib path from what I can tell. The mt-check.cgi says:

Perl include path:
plugins/WXRImporter/lib
plugins/StyleCatcher/lib
plugins/TypePadAntiSpam/lib
plugins/MultiBlog/lib
plugins/WidgetManager/lib
plugins/Textile/lib
plugins/spamlookup/lib
/var/www/html/mt/extlib
/var/www/html/mt/extlib
/var/www/html/mt/lib
/usr/local/perl-5.8.8/lib/5.8.8/i686-linux
/usr/local/perl-5.8.8/lib/5.8.8
/usr/local/perl-5.8.8/lib/site_perl/5.8.8/i686-linux
/usr/local/perl-5.8.8/lib/site_perl/5.8.8
/usr/local/perl-5.8.8/lib/site_perl
.

Also, certain CPAN modules just flat out won't update, like DBD::mysql. And some ones that are updated or installed aren't recognized, at least as far as mt-check is concerned.

Also also, it does the same thing even if I put it in the cgi-bin directory.

Any ideas where to start?

wildjokerdesign
08-04-2009, 07:59 AM
Would this page be of any help to you? http://faq.perl.org/perlfaq8.html#How_do_I_add_a_direc

lobstershell
08-04-2009, 08:10 PM
PERL5LIB is already set in my .bashrc, so alas, no.

wildjokerdesign
08-05-2009, 07:48 AM
I did some checking over at Moveable type and it seems as if the error you are getting now is often assoctiated with uploading files in binary instead of ascii mode. It has to do with line endings. In SSH you can use the command dos2unix to correct change a file that may have been uploaded in binary mode but since it is more then likely more then one it may be just as easy for you to upload the files again and make sure that they are uploaded in a ascii mode. I got this info from the mt forums here: http://forums.movabletype.org/2008/12/help-423-upgrade-error.html

lobstershell
08-10-2009, 02:35 PM
Saw that too. I actually use WGET in the ssh shell with the archives and then unarchive from the CLI. I have tried this with both the ZIP (unzip) and TGZ (tar xvzf) file. No joy in Mudville. :(

PS - Thanks for keeping on this.

lobstershell
08-11-2009, 03:38 PM
Figured out part of it: a full reinstall of Perl through the app manager works, but there are no extra modules installed. Once I drop into CPAN (using jalal's instructions here (http://forums.westhost.com/showthread.php?t=6859)), I get the 500 errors again. 2nd uninstall and reinstall confirms. Sigh. I guess I will be moving to WordPress.