View Full Version : Installing ElectroServer - hangs acct

12-05-2008, 10:40 PM
I could use some help if anyone has used ElectroServer on West Host before. I am currently trying to install version 4.0.6, but I also tried 4.0.4 (because I had successfully installed that version on a different host's VPS).

Basically all there is to the install is gunzip/untar the file from http://www.electro-server.com and then run ./ElectroServer from the folder. I installed to /opt/ElectroServer_4_0_6/.

I went to that folder and ran ./ElectroServer. The program appears to do the normal startup showing the computer info and then the java VM info, and it successfully shows the correct java version. Then, normally, it should say the line "ElectroServer has started successfully." However, it just sits there and never goes to a prompt or anything. I have to press Ctrl+C to quit it and return to a prompt.

I notice that while the program is at the "hung up" state, users cannot receive email, Outlook give the error that it cannot connect to the server.

I have tried reinstalling a few times, I tried removing and reinstalling Java JRE.

Please give some advice on successfull installs or if you have any ideas to try. I have been working with the developers of ElectroServer as well and they are stumped so far at this.


12-06-2008, 07:01 AM
Back in 2005 we where able to get it running somewhat. Have a look at this thread it might help you. http://forums.westhost.com/showthread.php?t=8130

I never used it on a production account just got it set up on a test account I used back then. It could be the original poster of that thread could shed some light on things if they are still around.

12-06-2008, 12:08 PM
Yes, I actually did find that post before adding this thread. Unfortunately, a lot could have changed on West Host's side in the last 3 years and I know a lot has changed on the ElectroServer side since then. A big problem he had was enabling the web admin, now that is standard.

The current version tries to use for connections on ports 8080, 9898, 9899 by default. Any idea if these ports are blocked or not available? I talked to West Host via live chat and that person only knew that 8080 is not blocked, which makes sense because I can open the web admin page via port 8080 after starting the program. The problem is in the page it only says the server is not running, no errors or anything.

12-06-2008, 06:51 PM
I you would like to PM a copy of ElectroServer, I can take a look and see if I can determine anything. Like I say it has been years since I played with it but willing to investigate. :)