PDA

View Full Version : formmail path - "This Page Not Found" Error



Pipe Dreams Marine
09-03-2008, 10:46 AM
I'm trying to setup my formmail script. I have the following path in my contact.htm file:

<form method="POST" action="http://www.pipedreamsmarine.com/cgi-bin/formmail/FormMail.pl" target="_top">

And I have uploaded the file FormMail.pl to:
/var/www/cgi-bin/formmail/

In my FormMail.pl script, I have tried the lines:
$mailprog = '/usr/lib/sendmail -i -t';

AND,I also tried:
$mailprog = '/usr/bin/perl';

I wasn't sure which to use...

When I test my form, I get this error:

"The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be
experiencing technical difficulties, or you may need to adjust your browser
settings."

And on the error page, the path in the URL reads:
http://www.pipedreamsmarine. com/var/www/cgi-bin/formmail/FormMail.pl

(No space of course, but without it, it wants to make it an abbreviated link) But, it's not even the path I used!?

Tech Support said that I needed to use:
<form method="POST" action="http://www.pipedreamsmarine.com/cgi-bin/formmail/FormMail.pl" target="_top">

(which, I did and it didn't work - see above) but that they couldn't assist further as I had a custom version of formmail (!?!?) (which I downloaded from www.scriptarchive.com/formmail.html) and that if I needed further assistance to post in a forum or pay for custom services.

I've been trying to figure this out for days and I'm just stumped & frustrated. Any advice?? It'd be greatly appreciated!

wildjokerdesign
09-03-2008, 02:05 PM
Why aren't you simply using the WH provided FormMail script? Is this perhaps for a secondary domain and not the main one? Do you have any .htaccess files that you are using in your public web directories?

If you are going to use Form Mail, do not use the one from Script Archive. Instead use the one here: http://nms-cgi.sourceforge.net/ Neither of these versions are the best choice as they are no longer being maintained to keep up with current spamming techniques but the second choice may give you better security.

shakmatay
09-03-2008, 03:24 PM
Hello Pipe Dreams,

Here's one thing to check...

AFTER you uploaded the perl file to your cgi-bin, did you change the file permissions? The script won't work unless you chmod it to 755.

Let me know if that does the trick (depending on which $mailprog line of code your using in the perl script).

You mentioned two different $mailprog lines of code. If neither of them work after changing the file's permissions, then try the following for your $mailprog line....

$mailprog = '/bin/sendmail -i -t';

Just remember, you MUST chmod the file to 755 (every time) after it is uploaded.

Hope this helps,
Shakmatay