PDA

View Full Version : Compiler collection messed up after upgrade...



Wiggins
06-15-2007, 10:07 AM
I got the notice about the server switch, which I really appreciate some hosts don't warn you about this kind of stuff. But there was definitely an issue with the upgrade breaking the installed compiler collection that WH might want to look into before doing any more of them. I had a certain popular IMAP server installed in a local location for months that has been working beautifully, and after the server upgrade failed to work. The error essentially boiled down to:

system library:fopen:No such file or directory

Attempting to then reinstall the application from a newer (more stable) version gave at the configure stage:

checking how to run the C preprocessor... /lib/cpp

Followed by an error about the cpp not being sane which I don't seem to have in my scroll buffer.

After uninstalling and reinstalling the compiler collection the original installation worked again and the new version builds cleanly. Nice to have my mail back :-).

rolling
06-15-2007, 11:15 AM
I wondered whether that sort of thing would break. I'm not sure what is involved in the server switch, whether it is simply a case of new hardware, or whether the operating system is upgraded at the same time to RHEL 4 (I think that's what they were promising)

Obviously Westhost only support those applications installed from the Site Manager, so anybody who has installed things on their own will have a more bumpy ride. I wish that they would give us a temporary account on the new server for a month / week so that we could move our sites over ourselves, with minimum disruption.
If I'd had more free time during the beta test, I would have rebuilt my packages ready for the switchover :/