To administer your WestHost account, please enter your
Domain Name or Server Manager Username.

WestHost: Professional Website Hosting Company








Results 1 to 5 of 5
  1. #1

    Default enabling Permalinks for WordPress in a subdomain

    I've installed WordPress 2.9.1 by hand (not using the Site Manager) in a subdomain, http://blog.grumm.com/ (/var/www/blog). I have a WH3 account. Everything seems to work until I enable Permalinks.

    Using the default WordPress installation I click on the "About" link, http://blog.grumm.com/about/, and get a 404 error. When Permalinks are disabled it works.

    I did install WordPress in it's own directory (/var/www/blog/wp) but I've tired a standard installation as well with the same behavior.

    I'm assuming that this is some sort of problem with the .htaccess file or httpd.conf but don't know how to fix it.

    Any help is greatly appreciated.

    .htaccess
    --------------------------------------------------------
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    httpd.conf (partial)
    --------------------------------------------------------
    <VirtualHost *:80>
    ServerName blog.grumm.com
    ServerAlias www.blog.grumm.com
    DocumentRoot /var/www/blog
    </VirtualHost>

    wp-config.php (without the DB details for security)
    --------------------------------------------------------
    define('WP_SITEURL', 'http://blog.grumm.com/wp');
    define('WP_HOME', 'http://blog.grumm.com/');
    define( 'WP_CONTENT_DIR', '/var/www/blog/wp/wp-content' );
    define( 'WP_CONTENT_URL', 'http://blog.grumm.com/wp/wp-content');
    define( 'WP_PLUGIN_DIR', '/var/www/blog/wp/wp-content/plugins' );
    define( 'WP_PLUGIN_URL', 'http://blog.grumm.com/wp/wp-content/plugins');
    define ('WPLANG', '');
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
    require_once(ABSPATH . 'wp-settings.php');

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,687

    Default

    Since you installed your wordpress outside of the normal public root (var/www/html) you need to edit the httpd.conf file.

    Here is what you need put in the Virtual Host tag for the subdomain in question.

    Code:
    <Directory "/var/www/blog">
    	AllowOverride All
    	Order allow,deny
    	Allow from all
    	</Directory>
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  3. #3
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,687

    Default

    Actually here is what your httpd.conf should look like after altering:

    Code:
    <VirtualHost *:80>
    ServerName blog.grumm.com
    ServerAlias www.blog.grumm.com
    DocumentRoot /var/www/blog
           <Directory "/var/www/blog">
    	AllowOverride All
    	Order allow,deny
    	Allow from all
    	</Directory>
    </VirtualHost>
    The above spacing is not really important but wanted you to see the new addition easily.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  4. #4
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,687

    Default

    Something else you might want to look at is the fact that you can not access this subdomain with the www prefix although the Virtual Host tag makes you think that you can. You would actually have to create another subdomain of www.blog for it to work. Kind of a workaround in WH 3.0.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  5. #5

    Default

    Thanks Shawn! That fixed it.

    I hope WestHost takes good care of you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •